Support » Installing WordPress » white screen after activating a theme and after reinstalling

  • Resolved missmoffat


    I have the dreaded white screen problem.
    I want to use a theme which is compatible with WordPress 3.0, so installed a previous version of WordPress which I had on my computer, instead of downloading 3.0.1.
    The installation went fine but then when I activated the new theme, I got the white screen. Looking into it I realised I had made the basic error of actually installing an older version of WordPress (2.7). Newbie mistake! So I deleted all the WP files from the remote site and from the database and then did a completely fresh installation with WordPress 3.0.
    I hoped this would mean I could start again but instead I still have a totally blank screen and can’t even complete the new installation as get the blank screen for that page too:
    Feeling very stuck now – any tips would be great.

Viewing 14 replies - 1 through 14 (of 14 total)
  • I’m having the same problem – installed a new theme and didn’t check if it displayed properly before activating it.
    Wouldn’t you know it doesn’t.

    so i reinstalled/updated the version of wordpress via my webhost.
    Now even when I go to the wp-admin screen, I can’t log in. It’s the white screen.

    However, I just noticed that the reinstall has moved the login to domain/worpress/wp-login.

    Dunno if this helps you missmoffat. I’ve gone and lost all my posts and have to start from scratch. Hopefully someone will be able to help you out.

    Thanks steevil

    Good to know I’m not on my own with that white screen!

    I think it can happen that when the whole wordpress folder is uploaded it creates a /wordpress/ subdomain – it sounds like that’s what’s happened with your reinstall. What I’ve done is load up the individual files straight into /htdocs and this way the site appears at the main domain. Hope that makes sense and good luck..

    Still scratching my head in front of the white screen but have a bit more info. if could be of use for someone to help.
    Looking through the forum I saw advice to define these two variables in the wp-config.php file at top
    define( ‘WP_DEBUG’, true );

    define( ‘WP_DEBUG_DISPLAY’, true );

    I did this and it brought up the following error message:
    Warning: Unterminated comment starting line 3478 in /home/linweb03/e/ on line 3478

    Fatal error: fatal flex scanner internal error–end of buffer missed in /home/linweb03/e/ on line 3478

    I haven’t made any changes to the functions.php file but went into to have a look at line 3478 and it’s simply this:

    Moderator James Huff


    Access your server via FTP or SFTP, navigate to /wp-content/themes/ and rename the directory of your currently active theme. This which will force the Twenty Ten theme to activate.

    As for the theme you’re trying to use, I recommend deleting it and finding an alternative.

    The only theme I have in the themes folder is Twenty Ten because when I got the problem I deleted everything from the remote site and the database and did a completely new install.
    Is there a chance the theme I was trying to use is still in the system somewhere and I haven’t completely got rid of it?

    Moderator James Huff


    No, if you deleted the files it’s gone for good.

    Try manually resetting your plugins. If that resolves the issue, reactivate each one individually until you find the cause.

    Thanks very much James

    I only had akismet in the plugins folders, as it was a whole new install but did follow the guide about manually resetting the plugins.

    Sadly it didn’t work – I still come up with the same error message about line 3478.

    I must admit I’m getting quite frazzled now as I meant to spend these days working on the site to show to a client on Tuesday and I can’t find much info on the web about that particular error message.

    Moderator James Huff


    Try downloading WordPress again and delete then replace your copies of the /wp-admin/ and /wp-includes/ directories with fresh copies from the download.

    Thanks again for your help with this James.

    I’ve deleted and replaced those two directories and now just get the white screen without the error message that was showing before – may be some progress? Alas still baffled though!

    Moderator James Huff


    We’re closer, that’s good. Now try replacing everything else, except the /wp-content/ directory and the wp-config.php file.

    Actually before I read your message I decided to delete everything and start all over again.
    I deleted the files from the remote server and uploaded them afresh.
    Still got the white screen at the final stage of install

    I have carefully checked that I have all the correct database information in wp-config.php.
    However, when I went into the database I found there were no tables there – this is presumably because they get created when you finish the install?

    I contacted my web host, who ran a testphp.php which worked fine, so their suggestion is that my wp files are corrupted in some way. I have used these files successfully before and haven’t made changes to them and am being thorough about uploading them to the remote server, so still completely stuck!
    Sorry it’s turning into such hard work!

    Moderator Ipstenu (Mika Epstein)


    Lead Plugin Wrangler

    The tables get created after you run the install, yes.

    Download a fresh copy of the wordpress zip. It can’t hurt at this point.

    Also, what version of php do you have on the server?

    Thanks very much ipstenu and to all who tried to help to me on this.

    Finally a whole fresh copy as you suggested and another complete new install has sorted the problem out. Not got to the bottom of what was going wrong but just very relieved!

    Moderator James Huff


    You’re welcome!

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘white screen after activating a theme and after reinstalling’ is closed to new replies.