White Screen (49 posts)

  1. xtitan27x
    Posted 4 years ago #

    So I got this white screen of death everybody has been talking about. The problem is there is no way around it. When I deleted some of the code I made sure to copy just in case I deleted the wrong thing. So when I hit update went white. So I hit back and pasted what I copied and hit upload. White again. Went to my website white. I didn't have that much completed on my website so I decided to uninstall wordpress and start over. Got my new password and logged in. Tried to activate a one of the generic templates "selecta." Went white again. Please help! I don't do a lot of business off my site but not having one will hurt me especially with wedding season around the corner. Thanks all.

  2. esmi
    Forum Moderator
    Posted 4 years ago #

    - switching to the Twenty Eleven theme by renaming your current theme's folder in wp-content/themes and adding "-old" to the end of the folder name using FTP or whatever file management application your host provides.

    - resetting the plugins folder by FTP or phpMyAdmin.

  3. xtitan27x
    Posted 4 years ago #

    The page I even log into now is white screened! Running off of Safari and the newest Firefox.

  4. xtitan27x
    Posted 4 years ago #

    http://www.mywebsite.com/wp-admin/ thats the site they want me to log in to to edit my page

  5. esmi
    Forum Moderator
    Posted 4 years ago #

    Please re-read the steps I gave above.

  6. hitmanhannan
    Posted 4 years ago #

    I just did what you suggested and it didn't work. My site is http://workfromhomechristians.com.au

    the site is up but I can not get into the admin area, it is just white

  7. xtitan27x
    Posted 4 years ago #

    Ya I am not that lets just say an expert at this so reading all that goes over my head

  8. esmi
    Forum Moderator
    Posted 4 years ago #

    I'm afraid that this is basic WordPress troubleshooting and, as a site owner, you should know how to upload, rename and delete files or folders using FTP. If you cannot manage this yourself, perhaps you need to try hiring someone?

  9. Genek1
    Posted 4 years ago #

    Pretty tough love response. These folks are new. Like me. Until you try messing with the editor/themes and get the white screen of death, you probably have not had a need to use ftp if you are using a WordPress theme through a hosting company like Bluehost.

    I also got the white screen today and found myself not able to get into the wp-admin control as well. My whole website went white after altering the code in the theme php editor (Ironically, I was trying to reduce the white space in my twenty eleven theme above and below the header!). However, I went into the cPanel of my hosting company and clicked on FTP session control and was able to change the name of the child theme, as advised earlier. The website was still quite messed up and so I switched themes to the twenty eleven parent, deleted my child theme, and then created a new child theme. No more problems. Hope this plain language helps someone.

  10. Snowyn
    Posted 4 years ago #

    I'm having similiar White Screen Of Death problem. I'm working on a host I've never used before. And it's Windows hosting, which I am not familiar with. My access is only through Dreamweaver. Using a Mac OS 10.4 (yes, I know: ancient.)

    How I installed: uploaded a zip file to the root directory and unzipped it using a cpanel-style interface. This created a wordpress directory. I created the mySQL database manually, and edited wp-config.php manually. Then I did the install.php, and all was okay. I was able to log in, create a new theme, create several pages.

    The symptoms: Originally, I was able to view the home page (at http://mydomain.com/wordpress/home), which was the "new" static home page in the Settings:Readings admin area. That was how I built the new theme (making css changes and php changes on Dreamweaver and uploading). Attempts to see other pages gave 404 errors. However, I figured once I put the WordPress index.php in place at root, all would be well. (I had an under-construction page at the root index.php.) However, when I did that, I started getting the White Page of Death. So I tried a bunch of things, namely:

    1) moving the files to the root directory using Dreamweaver "drag it" functionality. More white pages of death throughout. Now even the home page is white screen of death.

    2) deleting the entire wordpress directory and re-unzipping it from the .zip file. More white pages of death.

    3) deleting the files from root, unzipping them on my computer, and uploading them "manually". More white pages of death.

    4) removing all tables from database, redoing the install.php, and then uploading only the pages from the exported database file. (via an .sql file edited down from the original backup.) Still white pages of death.

    I do not have any plugins installed. I even renamed the plugins directory. I have mostly always been able to log in and to access the admin pages. No white screens there.

    Ah, yes, I also reactivated the Twenty-Ten theme. Still white screen of death.

    Can anyone help? Thanks!

  11. kmessinger
    Forum Moderator
    Posted 4 years ago #

    My access is only through Dreamweaver.

    Then something is very wrong (I use DW)).


    What happens when you try that?

    And for ALL - please! Give us a real URL.

  12. kmessinger
    Forum Moderator
    Posted 4 years ago #


    I see the admin login just fine. Is there another problem?

  13. Snowyn
    Posted 4 years ago #

    on http://www.url/wp-admin
    this is fine. I can login and see the admin pages.
    "By access only through DW", I meant I do not have telnet access or access to any sort of shell. The hosting service provides only very limited access.

    The site is
    an additional page should show up as
    but this is also white screen of death. As is also:

    I also just saw that WordPress will not write an .htaccess at root directory. I was able to make a .htaccess (for permalinks) in the wordpress directory when I had that. And since this is a Windows platform, that is likely a problem that I don't know how to solve. I prefer permalinks!!

  14. kmessinger
    Forum Moderator
    Posted 4 years ago #

    The hosting service provides only very limited access.

    DW is great for access, etc.

    I prefer permalinks!!

    If you are using IIS 7 and have admin rights on your server, you can use Microsoft's URL Rewrite Module instead. http://codex.wordpress.org/Using_Permalinks

    With access to the back end have you changed permalinks to the default? Can you see those pages from the page editor? Do the pages have something in common that other pages do not? Is there code on the page when you view source? It is harder to debug from a distance when the site is "under construction." Maybe you could switch to twenty11 and go live so we can see it?

    If all else fails . . . being on a windows server with limited access is a problem. You have tried all the normal debugging. I would try again with a complete "new" install, db, etc. and make sure wp is working with the included themes, out of the box before making any changes.

  15. Snowyn
    Posted 4 years ago #

    What I meant by "limited access" is exactly that I do not have admin rights/access on the server. The only access I have to the server is via ftp (and I generally use DreamWeaver instead of Filezilla). And as you say, that's a problem.

    My client only needs a "little" site. I wanted to do WordPress so he can change it himself. (Among other things, it's in Portuguese -- which I cannot read!) So I've gone ahead and made an ordinary site for him so he'll have a live, functioning site.

    So, thanks for letting me know I've already tried pretty much all the debugging strategies. I had never before encountered a white screen of death unless something was wrong in my own PHP code. So, yes, I'll try a complete new install one of these days, and as you recommend, make sure wp is working with default theme before doing anything more. Then one step at a time.

  16. Snowyn
    Posted 4 years ago #

    And to answer your other questions, there are only three pages, two with content and one with a form-plus-some-content. All of them displayed white page of death after I started messing around with the reinstalls. The page editor will show the content of the page in the edit window, but clicking on "view page" leads only to white page of death. Before I started messing around with reinstalling, the "view page" led to 404 error for the two not-home pages. I COULD see the home page using the permalink to that page. (Ie, http://advogadopeter.com/home) After the reinstalls and white page of death, I switched to twenty-ten theme and got the same white page for all three pages. This suggests the original install was okay (in wordpress folder), but permalinks got screwed up somehow. Strange that the home page would show up using the permalink, but dicas and the other went to 404 not found. And yeah, working "behind the scenes" with a non-wp index.php file at the root directory does tend to make life difficult. I figured that was why there were 404's for the two non-home pages. (In other words, in Settings>Reading, I put a static page as home page, namely the one called "home". In the original install, I COULD see that page with the permalink, but not the other two.)

    And thanks for your assistance!

  17. resentin
    Posted 4 years ago #

    Hi everyone. A newbie here as well, I hope I'll find some idea on how to sort this blank page issue.
    Briefly the story:
    Website hosted on fasthosts.co.uk. I had uploaded WP via Filezilla, everything worked after fixing the DB_host reference. Installed a theme and created some content. The site was up and running, but last December it was hacked. Through FTP I've removed the whole content. One directory (x) wouldn't delete, the webhost assured me it is a system folder that can be left. I uploaded the most recent backup but didn't work. I removed everything again and started with a fresh installation of the last WP (3.3.1), changed the DB-host reference and...
    blank page.
    After reading all the support pages I've increased the memory to 64M, no difference.
    Now, the installation is just fresh and the links in the wp-config seem to be all fine (a quick change test displays error messages).
    There are no themes nor plugins installed.
    http://mywebsite/wp-admin/install.php says WP is already installed.

    Any idea would be much appreciated. Thanks in advance!

  18. esmi
    Forum Moderator
    Posted 4 years ago #

    What version of WordPress were you running when you made that database backup?

  19. resentin
    Posted 4 years ago #

    Not too sure as I had gone through some automatic WP updates. I believe 3.1.3 though.

  20. esmi
    Forum Moderator
    Posted 4 years ago #

    Try looking through the database backup file for the data relating to the wp_options table. Look the option name db_version and make a note of the value for that field. That will help us to determine which version of WordPress that backup is compatible with. The database structure changes from version to version so you can't (for example) use a 3.1 database with 3.3 core files.

  21. resentin
    Posted 4 years ago #

    Sorry I misunderstood. I have no backup of the database. I only had a backup of the htdocs folder, which I believe were hosting WP in its 3.1.3 (or slightly later) version.
    I guess the database hasn't been touched as I haven't done anything on it.
    I have now seen I can have some access to it through phpMyadmin but have no clue as to what should I do with it. Sorry as I said I have some IT background but no specific php or webdesign experience.

  22. Dexmaster
    Posted 4 years ago #

    First of all maybe a problem was during reinstall. You need to:

    • find out if all WP files are present and replace all 0 sized php files by good ones
    • *most whitescreens are from this problem.

    • find out if your provider has something like php/site error log it will help identify error
  23. Ryan Steyn
    Posted 4 years ago #

    I have had the whitescreen issue for the past few days, it occured during my attempt in getting h2 tags to live through the excerpt stripping procedure.

    In my attempt I found an overall solution that made my previous excerpt length and read more links redundant so I copy and pasted the entire function with all the whistles - to cut a long story short, the issue is in the excerpt length when used as so...

    function string_limit_words($string, $word_limit)
      $words = explode(' ', $string, ($word_limit + 1));
      if(count($words) > $word_limit)
      return implode(' ', $words);

    After removing a similar snippet from my functions.php, all is back to normal.

    This solution was found by a member named "clickit" about 2 years ago.

  24. Ryan Steyn
    Posted 4 years ago #

    RE: my previous post above
    That solution only seems to work for +- 24hours, found another solution which suggested the removal of white space below the closing ?> tag.

    Worked like a charm, if it gives me the white screen of death again after a few days I will post yet another "found" solution.

    PS: the best test to see if a fix is working is to...

    1. try access the admin
    2. If you are already in the admin, preview a post

    If you can accomplish both of those, you are not a sufferer of the white screen.

  25. trevorehlers
    Posted 4 years ago #

    Hello there- white screen occurring - I am a newbie...please excuse the post length.

    I have a feeling that it has something to do with altering the theme-functions.php
    or the functions.php...
    When I have tried to upload original these files again as they were originally configured - it did not change-I still can't even access my admin screen.

    I also have someone at my hosting account who gave this response that might be causing it:

    Please look into undoing whatever changes you pushed towards your site. Looking over the php_error.log located in the following folder we are seeing the included errors: /www.ehlersdesign.org/logs/

    [23-Feb-2012 00:57:18] PHP Fatal error: require_once() [function.require]: Failed opening required 'TEMPLATEPATH/functions/admin-setup.php' (include_path='.:/usr/share/pear') in /mnt/stor12-wc2-dfw1/597084/650323/www.ehlersdesign.org/web/content/wp-includes/functions.php on line 6
    [23-Feb-2012 00:58:34] PHP Warning: require_once(TEMPLATEPATH/functions/admin-setup.php) [function.require-once]: failed to open stream: No such file or directory in /mnt/stor12-wc2-dfw1/597084/650323/www.ehlersdesign.org/web/content/wp-includes/functions.php on line 6
    [23-Feb-2012 00:58:34] PHP Fatal error: require_once() [function.require]: Failed opening required 'TEMPLATEPATH/functions/admin-setup.php' (include_path='.:/usr/share/pear') in /mnt/stor12-wc2-dfw1/597084/650323/www.ehlersdesign.org/web/content/wp-includes/functions.php on line 6"

    Please let me know if anyone has any tips...thanks so much. Trevor

    Also would appreciate it if anyone even knew where to find the wp-includes folder if mine is corrupted on the host maybe I could try replacing that...OK Thanks for your help!

  26. trevorehlers
    Posted 4 years ago #

    Also my site is http://www.ehlersdesign.org

    thanks again

  27. Dexmaster
    Posted 4 years ago #

    You already wrote an answer to your question the file is missing "TEMPLATEPATH/functions/admin-setup.php"

  28. trevorehlers
    Posted 4 years ago #

    OK thanks so much Dexmaster. I just replaced the entire wp-includes folder and it worked! back in business now. So happy! I have a lot to learn. Appreciate it.

  29. Dexmaster
    Posted 4 years ago #

    Or it could be as follows this file was not created but was asked in your
    "/wp-includes/functions.php" on line 6 (look for work line not comments)
    there will be something like require_once(TEMPLATEPATH/functions/admin-setup.php)

  30. sunrayshining
    Posted 4 years ago #

    Hi Esmi and co!

    I carefully followed the steps to instal a child theme, but when I activated it came up blank. Now the blank is everywhere.


    I deleted the child theme directory, but that didn't solve the problem. What about deleting the hta file?

    What's the best way to get admin back again?

    Thanks in advance!

Topic Closed

This topic has been closed to new replies.

About this Topic