Support » Plugin: Genesis Club Lite » White screen 1.7.1

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Russell Jamieson

    (@powerblogservice)

    Hi, Do you know what version of PHP you are running?

    Plugin Author Russell Jamieson

    (@powerblogservice)

    Please post the URL of the site. Thanks

    Thread Starter amazemedia

    (@amazemedia)

    php version 5.2.17

    parkviewguesthouse.com/beta but I rolled back to 1.6 so site would work.

    Plugin Author Russell Jamieson

    (@powerblogservice)

    Many Thanks for getting back to me.

    It looks like I have inadvertently put in a PHP 5.3 dependency.

    5.2.17 was released in 06 January 2011 and has been at “end of life” for some time. WordPress will probably no longer support PHP 5.2 for more than another year so you will need to upgrade your PHP to 5.4 or 5.5 fairly soon anyway.

    PHP 5.5 is standard on new hosting accounts.

    That aside, the plugin should still support a minimum of 5.2.4 so I will identify what PHP 5.3 I have used and then push out a PHP 5.2 fix in the next day or so.

    Plugin Author Russell Jamieson

    (@powerblogservice)

    Genesis Club Lite 1.7.3 has been released. This fixes this issue for sites on PHP 5.2.

    In version 1.7.1 I had introduced a closure (anonymous function) in the Display module which is a PHP 5.3 feature and hence this broke any PHP 5.2 site.

    In version 1.7.3 I use a normal named function instead hence it will work fine on PHP 5.2 installations

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘White screen 1.7.1’ is closed to new replies.