Support » Plugin: W3 Total Cache » White pages and htaccess

  • Resolved alleycakes

    (@alleycakes)


    I just started using this plugin and was told by Dreamhost to “configure
    W3-total-cache within your .htaccess file, as it will not work properly
    unless it is setup within”. I’m not really sure what this entails or where to go to find this file to modify.

    Also, I’m getting blank/white pages whenever I do certain things on the admin side like create/delete a page or activate/deactivate a plugin. I can always go back to the admin panel by typing in the URL again, but it’s really annoying and inconvenient to have to do this all the time.

    Any help on these issues would be amazing!

    https://wordpress.org/plugins/w3-total-cache/

Viewing 15 replies - 1 through 15 (of 17 total)
  • Mika Epstein

    (@ipstenu-dh)

    DreamHost Rep

    W3 Total cache generally can auto-add teh information needed to your .htaccess.

    We have some information at DH about the file though: http://wiki.dreamhost.com/Htaccess

    A blank white page is generally a PHP error, though, which probably means you’re running out of memory. What’s your domain? I can have a look, if you’d like.

    alleycakes

    (@alleycakes)

    Thank you! The domain is raccoonsociety.com

    As you can see, it’s terribly slow to load, which is why I contacted Dreamhost and they told me to modify the htaccess file (disabling plugins and removing widgets didn’t help at all).

    This is all just outside of anything I’ve done before, so I need someone to hold my hand at every step while I learn haha.

    Mika Epstein

    (@ipstenu-dh)

    DreamHost Rep

    So when you log in to your site, doesn’t it tell you that you need to finish the setup of W3TC?

    I would actually suggest you try WP SuperCache FIRST 🙂 W3TC is awesome and I love it, but WP Super Cache is easier, smaller, and less daunting for that first time.

    You’re running a site with bbpress and BuddyPress, both of which pretty much will make your site run slower than normal because they’re membership sites. And you have about 100 active users too, so … yeah, you make just be too big and busy for shared now.

    alleycakes

    (@alleycakes)

    I did go through and configure everything in W3TC. I enabled everything I could without it completely breaking the site.

    I did try WP Super Cache. The site was still ridiculously slow, but now it takes literally twice the time to load with W3TC. I was told by DH not to use WPSC and to switch to W3TC though. The whole issue is that the site is just so slow, and I’ve been doing everything they recommend. It’s just not speeding up at all, and now it’s gotten slower.

    Also, the site is on a VPS.

    I’m losing hope. 🙁

    Mika Epstein

    (@ipstenu-dh)

    DreamHost Rep

    Ah a VPS does change things. WPSC is great for shared. W3TC is better on a VPS.

    W3TC is inactive right now so it’s hard to really tell without actually logging in and testing myself, but you have a pretty high server load so that’s going to slow you down.

    I suggest the following:

    1) Remove some plugins. buddypress-post-ratings and wanguard are both good plugins, but they may be slowing you down a little.

    2) Optimize your VPS. Go to https://panel.dreamhost.com/index.cgi?tree=vserver.settings& and do the following:

    * Turn on PHP cache
    * turn OFF Jabber

    3) Consider Google Pagespeed. If you go to https://panel.dreamhost.com/index.cgi?tree=domain.manage& and click on edit for your domain, you can change PHP settings there. I would try (and please understand this may not work perfectly) checking the box for “Page Speed Optimization?”

    4) Consider PHP 5.4 – Many people reported a 15% speedup on their sites. Same page as page speed, just change the drop down to PHP 5.4 FastCGI

    alleycakes

    (@alleycakes)

    I disabled W3TC for now so I could see the different in load times. I can go ahead and enable it again if you think you can help with it.

    1. I did try disabling all other plugins, but unfortunately, it didn’t help load times at all.

    2. PHP cache is already enabled. I do not see Jabber in that panel in particular. If I go to “Jabber IM” under the Goodies section, there are no users, so I assume it’s disabled?

    3. I tried Pagespeed until last week when the last DH tech I spoke with told me to disable it. I didn’t see a difference in load times one way or the other anyway. (I confirmed with Google that it was in fact set up properly, so I know that wasn’t the issue.)

    4. Are there any risks in switching to PHP 5.4? If it breaks anything, will I be able to go back to 5.3 and have everything work again?

    Mika Epstein

    (@ipstenu-dh)

    DreamHost Rep

    Item 2: Are you on https://panel.dreamhost.com/index.cgi?tree=vserver.settings& ? This is a separate page for your VPS.

    3. PageSpeed is hit or miss :/ If you’re using OURS the fastest way to make sure it’s working is to view page source and see if it compressed things.

    4. Nope. You can switch back and forth very easily via ttps://panel.dreamhost.com/index.cgi?tree=domain.manage&

    alleycakes

    (@alleycakes)

    2. Oh! It had me log in first, and it didn’t take me back to the page you had linked. I see it now, and I changed the settings for PHP cache and Jabber as you recommended.

    4. Okay great. Switching now.

    I’ll let you know if these seem to reduce page load times in a couple of days. Thanks so much for your help with this. 🙂

    Mika Epstein

    (@ipstenu-dh)

    DreamHost Rep

    Awesome 🙂 I’m getting email alerts for this thread too 🙂

    alleycakes

    (@alleycakes)

    So after giving it a couple days, it still doesn’t seem to be loading any faster. I switched to PHP 5.4 and re-enabled W3TC. I disabled Wanguard at the same time as well.

    Now that I enabled W3TC again, the white pages are back too, as I described in my original post.

    Any other suggestions? 🙁

    Mika Epstein

    (@ipstenu-dh)

    DreamHost Rep

    W3TC is installed, and active, though not configured from what I can tell.

    What options did you pick in it? I know it’s a MASSIVE complex plugin.

    alleycakes

    (@alleycakes)

    I initially tried to enable everything, but I was getting error messages, so I went through and started enabling things one by one and checking each one to make sure it didn’t break anything. Here’s what I have enabled currently:

    Page Cache (Opcode: XCache)
    Minify (Manual, Opcode: XCache, HTML/JS/CSS Defaults)
    Browser Cache

    Everything else caused errors to pop up when I enabled them.

    Mika Epstein

    (@ipstenu-dh)

    DreamHost Rep

    Well that explains a lot 🙂

    Page Cache : Disk Enhanced

    Minify: Manual, Disk Enhanced.

    Browser Cache

    I know you’d think “I have X-Cache, I should use it!” but you don’t want to here.

    Okay I switched them. I’ll let you know in a couple days again if it seems to be helping. 🙂

    Actually I can already see it working. Yaaay! I just need to play around with the purge settings now. I’d like for the front page and View Questions page to reload whenever someone submits a new question, but the rest of the pages don’t need to re-cache every time that happens… if that makes any sense. I think I can figure that one out though. 🙂

    Thanks SO MUCH for your help!! Can’t tell you how relieved I am to get this working properly.

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘White pages and htaccess’ is closed to new replies.