• Resolved Li-An


    Hello, very interesting plugin. As I help a lot in french support forum, I suppose this plugin will be a great help. But it does not work at all on my test site.

    So: WP installed in a subdirectory, no other plugin activated, default theme and white page when cicking on Troubleshoot button.

    The plugin woks on the same hosting on a site where WP is installed in the root of the domain so I suspect a problem with the subdirectory installation.

Viewing 15 replies - 1 through 15 (of 17 total)
  • I’m having a similar issue – plugin giving me a whitescreen on my local site and giving me an “Unabled to read database credentials from wp-config.php” error on my hosted site. Hopefully this gets fixed soon as this plugin looks really useful.

    Plugin Author croixhaug


    Thanks @li-an for the note, we will test it in a subfolder and release a fix soon! I’ll update you here when we publish the update


    Plugin Author croixhaug


    Hi @li-an, I wanted to let you know that we just released an update (version 1.0.7) which should fix the issue you reported this morning! Please update to the latest version when you get a chance and let us know if it’s working for you now πŸ™‚


    It’s fixed for me. Thanks.


    I have made teh same expirience: White screen after cicking on Troubleshoot button (my installation is in a subdomain).

    The adress (with the white screen) is like this:

    The plugin sounds interesting, but it does not work.

    Thank you in advance!

    Plugin Contributor Natalie MacLees


    Hello @svensson36,

    Did you upgrade to version 1.0.7 that we released yesterday? It has fixes for some different installation situations, and it might have the fix for what you’re seeing.


    Hello Natalie,

    yes, I did the upgrade, and with this version I get the white screen

    Plugin Author croixhaug


    Hi @svensson36, could you enable WP_DEBUG in your config file. (adding this to wp-config.php):
    define(‘WP_DEBUG’, true);
    and seeing if there’s any error (instead of just the whitescreen) that you can paste us?

    If you contact us at that pro support email – support@tylerdigital.com – we’re happy to schedule a quick call/screenshare so we could see the issue live.

    To rule out other odd scenarios… do you know if this happens to be hosted on a Windows server or Linux server? If you could send us a copy of your wp-config.php file (please redact/change the password) to support@tylerdigital.com then we can also take a look to see if there’s some unusual formatting about it.

    Thanks, we’ll do our best to get to the bottom of it!

    Still white screen after update on my localhost, using XAMPP, PHP Version 7.1.1, Server version: 10.1.21-MariaDB. -windows machine.

    Here is the final URL of the white screen:



    • This reply was modified 1 year, 7 months ago by Luke.
    Plugin Author croixhaug


    Thank you, just confirming, the final URL is:

    instead of:

    in your filesystem, are the plugins inside of the wp-content/ directory? or are they in a different location? like public_html/plugins/ (assuming public_html is that path to the web folder)

    I will get access to a XAMPP Windows installation to test out, and post back here when I have some more information


    Hi Nathan,

    I have enabled WP_DEBUG, but there is no error message (both on my subdomain and on a localhost MAMP installation).

    This is my wp-config.php-file:

    define('WP_POST_REVISIONS', 5 );
    define('AUTOSAVE_INTERVAL', 600 );
    define('DISALLOW_FILE_EDIT', true);
    // wp-content rename
    define('WP_CONTENT_DIR', 'path-to-new-wp-content');
    define('WP_CONTENT_URL', 'http://subdomain.example.com/new-wp-content');
    define('DB_NAME', 'xxx');
    define('DB_USER', 'xxx');
    define('DB_PASSWORD', 'xxx');
    define('DB_HOST', 'localhost');
    define('DB_CHARSET', 'utf8');
    define('DB_COLLATE', '');
    define('AUTH_KEY',         'xxx');
    define('SECURE_AUTH_KEY',  'xxx');
    define('LOGGED_IN_KEY',    'xxx');
    define('NONCE_KEY',        'xxx');
    define('AUTH_SALT',        'xxx');
    define('SECURE_AUTH_SALT', 'xxx');
    define('LOGGED_IN_SALT',   'xxx');
    define('NONCE_SALT',       'xxx');
    $table_prefix  = 'wpxyz_';
    define('WP_DEBUG', false);
    /* That's all, stop editing! Happy blogging. */
    /** Absolute path to the WordPress directory. */
    if ( !defined('ABSPATH') )
    	define('ABSPATH', dirname(__FILE__) . '/');
    /** Sets up WordPress vars and included files. */
    require_once(ABSPATH . 'wp-settings.php');

    The PHP version of the is 7.1.17. I think it is a Linux server (Apache).

    Maybe the white screen has something to do with “wp-content”. I renamed the folder wp-content but the source text of the white screen refers to wp-content. So perhaps it is not possible to use the plugin in case of a renamed wp-content folder.


    • This reply was modified 1 year, 7 months ago by Svensson36.
    Plugin Author croixhaug


    Hi @svensson36, thanks this is definitely helpful. I believe it is WP_CONTENT that’s the issue. We’ll work on a fix for that today


    Woops sorry!

    I discovered the issue through chrome console, the files were showing 404 not found because they were being requested from my other server, I have been having db issues so this is not related to your plugin at all.

    np, yes that is correct it’s wp-content/plugins/plugin-detective/troubleshoot/?session=17&nonce=f433d9bb24

    My plugins are in wp-content/plugins dir.

    It is working.


    @svensson36 – open your console and check to make sure the pages are actually found when you are clicking on the troubleshooting link.

    • This reply was modified 1 year, 7 months ago by Luke.
    • This reply was modified 1 year, 7 months ago by Luke.
    Plugin Author croixhaug


    @svensson36, we just released version 1.0.9 which includes a fix for the custom WP_CONTENT_DIR and WP_CONTENT_URL issue. Please update to the latest and let us know if that solves the issue for you!

    Thanks for the update @wpfed, glad it’s working for you now!

    Hi Nathan,

    thank you very much, with version 1.0.9 it works!

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘white page’ is closed to new replies.