Support » Installing WordPress » white on white text when editing posts, WP 2.9, fresh install

  • Resolved photocurio


    with a fresh install of WP 2.9.2 i am getting a similar error to this post:

    I upgraded to version 2.8.1 and noticed that the visual editor is not working. TinyMCE does not show up at all, and sometimes the text in the visual editor box is white (you’d have to highlight it to see it). I disabled all my plugins but that didn’t fix it. Is anyone else having this problem? Is there a solution?

    the quoted thread referred the user to some threads suggesting she disable plugins, etc.

    plugins are not causing my white on white text: i have a fresh install, no plugins, with the default theme. and this is WP 2.9.2, not 2.8. why is this issue persisting?

    I think it has something to do with tinymce not loading, because when i go to my wp-tinymce.php page i see all the php code on my screen, and that can’t be right.

    when i open the tinymce.php page in dreamweaver, i see that it has no closing ?> tag and that can’t be right either. simply adding a closing php tag does not solve the issue. perhaps there is some missing code? i’m a designer, not a programmer. can anyone help?

Viewing 10 replies - 1 through 10 (of 10 total)
  • esmi


    Forum Moderator

    Try re-uploading the wp-includes folder from a fresh download of WordPress.

    done: fresh download, unzip, upload the wp-includes. site still has the same error when posting.

    the wp-includes/js/tinymce/wp-tinymce.php file is still missing a closing tag. the entire code on this page consists of:

    * Disable error reporting
    * Set this to error_reporting( E_ALL ) or error_reporting( E_ALL | E_STRICT ) for debugging

    $basepath = dirname(__FILE__);

    function get_file($path) {

    if ( function_exists(‘realpath’) )
    $path = realpath($path);

    if ( ! $path || ! @is_file($path) )
    return false;

    return @file_get_contents($path);

    $expires_offset = 31536000;

    header(‘Content-Type: application/x-javascript; charset=UTF-8’);
    header(‘Vary: Accept-Encoding’); // Handle proxies
    header(‘Expires: ‘ . gmdate( “D, d M Y H:i:s”, time() + $expires_offset ) . ‘ GMT’);
    header(“Cache-Control: public, max-age=$expires_offset”);

    if ( isset($_GET[‘c’]) && 1 == $_GET[‘c’] && isset($_SERVER[‘HTTP_ACCEPT_ENCODING’])
    && false !== strpos( strtolower($_SERVER[‘HTTP_ACCEPT_ENCODING’]), ‘gzip’) && ( $file = get_file($basepath . ‘/wp-tinymce.js.gz’) ) ) {

    header(‘Content-Encoding: gzip’);
    echo $file;
    } else {
    echo get_file($basepath . ‘/wp-tinymce.js’);



    Forum Moderator

    The lack of a closing tag isn’t an issue. It’s often a deliberate programming decision.

    Do you have any successful installs of WP running on the same server? If not, then it could be a server config problem.

    no other installs. i could check phpmyadmin. but what would i look for?
    can you see that page? it is all code. that just seems wrong. plus the fact that tinymce is also disabled on the posting page along with the white in white text.



    Forum Moderator

    That file shouldn’t be called directly but the fact that I can see code suggests that either the file is damaged/incomplete or there’s a problem with the server.

    OK, thanks for looking!

    anyone have advice for troubleshooting a faulty server configuation? looking over my install of wordpress, i believe the files are all complete and correct because:

    the install works on my laptop perfectly. it works on the live server, but with about 90% functionality, i.e. lots of little quirks. when i perform a synchronize with dreamweaver, the files are the same. so, i presume that it is a server config issue.

    this problem was caused by an Apache security module on the server – resolved now by disabling the security module..

    Would really help others to know which Apache security module was causing the issue and how you disabled it. Having same problem!



    I got the same problem: white screen in tinymce when editing posts, impossible to switch to HTML tab.
    Found the problem: it was generated by the Flash MP3 Player JW2.3 plug-in. Everything worked after desactivating it.
    However, I needed the plug-in so digged inside the code and just commented this line in class.config_editor.php in the Flash MP3 Player JW2.3 plug-in:
    Line 15
    So it’s now:

    /* Conflict with TinyMce editor:
        $this->include_color_picker(); */

    And everything works: the Flash MP3 Player JW2.3 plug-in and the tinymce Editor.
    By the way, here is the function that causes the damage:

    function include_color_picker(){
        if ($this->wp_ver >= 2.7){

    So you can see why this would only affects WP 2.7 or more…

    I hope this helps other people!

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘white on white text when editing posts, WP 2.9, fresh install’ is closed to new replies.