Support » Theme: Twenty Seventeen » White line appears between to-menu and header when not on mainsite

  • It works fine on the front page, but every time i change to another subpage, a white line appears, and I can’t solve the issue.

    I already have following custom CSS activated:

    .navigation-top {
    	border-top: 1px solid #4CA24C
    		!important;
    }

    what could be the cause? and more importantly, the solution?

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Hey, @hipolytos

    To do that, go to Appearance → Customize → Additional CSS and enter the following code:

    navigation-top {
      bottom: 1px;
    }

    Let me know if that does it.
    Thank you.

    No sorry. It didn’t do the job

    It’s not the bottom border, but the top border that’s the problem on every other page than the main homepage

    • This reply was modified 1 year, 1 month ago by hipolytos.

    Try this

    .site-header {
    background-color:your choice;
    }

    • This reply was modified 1 year, 1 month ago by lillan.
    hipolytos

    (@hipolytos)

    Thanks @lillan !

    It seemed to work. BUT, now I got another problem..

    So when you change the color, it seems to make a darker version of it.

    I’ll give you an example.

    Picture as an example

    what you can see is two shades of red. my custom CSS code is this:

    .navigation-top {
    	background: red
    		!important;
    }
    .main-navigation ul{
    	background: red
    		!important;
    }
    .navigation-top {
    	border-top: 1px solid red
    		!important;
    .site-header {
            background-color:red
    	!important;
    }

    got any idea what the problem could be?

    EDIT: BTW. @lillan . When I browse my website now, the utility bar in my browser switches color to RED. Pretty funky but quite weird…

    • This reply was modified 1 year ago by hipolytos.
    lillan

    (@lillan)

    It is the gradient area in site-branding. You can get rid of everything it with this:

    .custom-header-media:before {
    /* Permalink – use to edit and share this gradient: http://colorzilla.com/gradient-editor/#000000+0,000000+100&0+0,0.3+75 */
    background:transparent!important;
    }

    But take a look at your code:
    .site-header {
    background-color:RED
    !important;
    }

    Change the background-color i.e. use rgb instead if you want a red background-color, but you will still have a red line because of this:

    .navigation-top {
    border-top: 1PX SOLID RED
    !important;}

    Set it to zero (0).

    • This reply was modified 1 year ago by lillan.
    • This reply was modified 1 year ago by lillan.
    • This reply was modified 1 year ago by lillan.
    • This reply was modified 1 year ago by lillan.
    • This reply was modified 1 year ago by lillan.
Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘White line appears between to-menu and header when not on mainsite’ is closed to new replies.