• LinkAssist

    (@linkassist)


    Greetings –
    I’ve tried editing some of the pages at http://www.site-solutions.com, but found the text in the editor is all in white, and all the editor icons are missing. I tried the suggestions listed at http://learn.wpeditpro.com/troubleshoot-blank-wordpress-editor/ without luck.
    I de-activated all the plugins (& renamed wp-content folders to plugins-old and to mu-plugins-old), switched to Twenty Seventeen, re-installed WordPress 4.9.6, and manually cleared the browser cache – but the problem remained.
    While the plugins were de-activated and Twenty Seventeen was active, I also tried adding define('CONCATENATE_SCRIPTS', false); just after define('DB_HOST', 'localhost'); in wp-config.php, but the entire screen went white. No backend controls of any kind were visible. Once I removed that line of code, the backend re-appeared – but once again the editor only showed white text, and no editor icons were visible.
    This account is on a shared server, and has several add on domains in the same account. The other domains’ editors work normally.
    I’d really appreciate any hints as to how to hunt down the gremlin in the works!
    Dennis

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • Moderator t-p

    (@t-p)

    What did you do before this issue occurred? Update/install plugins? Update/install theme? update WP? Moved site? Anything else?

    Thread Starter LinkAssist

    (@linkassist)

    Thanks for the quick response @t-p.
    I’m fairly sure update(s) of the theme or plugins were the last things that occurred. I can’t be too specific though, because one of the plugins is Automatic Plugin Updates, so any minor updates occur unattended.
    Some progress…
    Using cPanel, I uploaded a fresh copy of the wp-includes directory as a zip file, deleted the old directory, and replaced it with the new (expanded) wp-includes directory. Afterward, the editor showed the page in black text <yeah!>, and showed both the Visual and Text tabs – but the editor is stuck in Text mode.
    I did the diagnostic dance again, de-activating all the plugins, activating Twenty Seventeen, and manually clearing the browser cache, but the editor remained stuck in Text mode.
    The hunt continues…

    Thread Starter LinkAssist

    (@linkassist)

    I don’t know how to interpret the following output – hopefully it will make sense to others.
    After de-activating all the plugins and activating Twenty Seventeen, I loaded a page in the editor at http://www.site-solutions.com and hit F12. The Inspector showed me a log file which I zipped as a txt file and left it at https://www.dropbox.com/s/uq51jlecsptr1ya/Error_log.zip?dl=0
    Any clues?
    Dennis

    Moderator t-p

    (@t-p)

    Troubleshooting with your browser: Your browser can help you identify JavaScript issues or conflicts and this article can assist you in doing that diagnosis. This could help identify Visual Editor issues as well.

    Thread Starter LinkAssist

    (@linkassist)

    Apologies for the late response @t-p. Life got in the way.
    I visited the article you suggested. Here are the results, but the numbers:
    1 – The error persisted in Chrome, Firefox, Internet Explorer, and Opera. Interestingly, the editor loaded in Chrome, Firefox, and Opera and showed the row of text buttons (b, i, link, b-quote, etc), while in Internet Explorer those buttons did not appear.
    2 – The error persisted after adding define('SCRIPT_DEBUG', true); just before Happy Blogging.
    3 – The console in Chrome contained the following (after I reloaded the page):

    /wp-admin/post.php?post=114&action=edit:277 GET https://www.site-solutions.com/wp-content/plugins/google-analytics-for-wordpress/assets/css/images/menu-icon@2x.png 0 ()
    inject.preload.js:373 GET blob:https://www.site-solutions.com/bc0eaad7-84ae-4777-bb34-889ebbc30acc 0 ()
    (anonymous) @ inject.preload.js:373
    __webpack_require__ @ bootstrap a58e717ca664391e8660:19
    splitSelector.splitSelector @ common.js:103
    __webpack_require__ @ bootstrap a58e717ca664391e8660:19
    exports.textToRegExp @ bootstrap a58e717ca664391e8660:62
    (anonymous) @ bootstrap a58e717ca664391e8660:62
    load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils,moxiejs,plupload&ver=4.9.6:9 JQMIGRATE: Migrate is installed, version 1.4.1
    nested.js?ver=ba049b38af3bdfb2c1538cef599fdd79:28 Uncaught TypeError: Cannot read property 'nodeName' of null
        at klass.initialize (nested.js?ver=ba049b38af3bdfb2c1538cef599fdd79:28)
        at new klass (nest-mootools.v1.11.js?ver=ba049b38af3bdfb2c1538cef599fdd79:361)
        at pagemash.js?ver=ba049b38af3bdfb2c1538cef599fdd79:84
        at returns (nest-mootools.v1.11.js?ver=ba049b38af3bdfb2c1538cef599fdd79:1424)
        at nest-mootools.v1.11.js?ver=ba049b38af3bdfb2c1538cef599fdd79:1429
        at nest-mootools.v1.11.js?ver=ba049b38af3bdfb2c1538cef599fdd79:2899
        at Array.forEach (<anonymous>)
        at fireEvent (nest-mootools.v1.11.js?ver=ba049b38af3bdfb2c1538cef599fdd79:2898)
        at nest-mootools.v1.11.js?ver=ba049b38af3bdfb2c1538cef599fdd79:3605
        at Function.<anonymous> (nest-mootools.v1.11.js?ver=ba049b38af3bdfb2c1538cef599fdd79:3609)

    … I have no idea what the console’s told me, however.
    Dennis

    Moderator t-p

    (@t-p)

    Try disabling google-analytics-for-wordpress plugin.

    Thread Starter LinkAssist

    (@linkassist)

    I disabled the plugin and pulled the editor back up again – no change.
    … for my next trick?
    Dennis

    Moderator t-p

    (@t-p)

    To rule out any other plugin conflict, or a theme conflict,

    Please attempt to disable all plugins, and use one of the default (Twenty*) themes. If the problem goes away, enable them one by one to identify the source of your troubles.

    If you can install plugins, install “Health Check”: https://wordpress.org/plugins/health-check/ On the troubleshooting tab, you can click the button to disable all plugins and change the theme for you, while you’re still logged in, without affecting normal visitors to your site.

    Thread Starter LinkAssist

    (@linkassist)

    Great plugin @t-p – thanks for the suggestion.
    Sadly, nothing changed. I have “Text” buttons available at the top of the editor, and HTML showing in the editor.
    Any other tricks up your sleeve?
    Dennis

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘White editor text & no editor icons’ is closed to new replies.