Support » Plugin: Yoast SEO » Which Yoast SEO version is compatible to WordPress 5.4.x?

  • Ov3rfly


    Which Yoast SEO version is compatible to WordPress 5.4.x?

    Current Yoast SEO 15.5 has WordPress 5.5 as minimum.

Viewing 14 replies - 1 through 14 (of 14 total)
  • Plugin Support Md Mazedul Islam Khan


    We are afraid to say that we are unable to confirm which Yoast SEO plugin version is compatible with WordPress v5.4 as we don’t offer support for an outdated version of WordPress, nor for our plugin.

    That said, you may want to take a look at the changelog to see whether you can find exactly what you need.

    Thread Starter Ov3rfly


    WordPress 5.4.4 was released only 6 weeks ago, that’s not outdated.

    And you might be aware of breaking changes in WordPress 5.5 which forced many sites with older plugins & themes staying in 5.4.x branch for now and some probably forever as their theme won’t be updated and they won’t change theme.

    Unfortunately can’t find 5.4.x support end date in the changelog.

    You might want to rethink your policy. With your current support policy your plugin is unusable for any WordPress older than 3.5 months.

    Plugin Support Md Mazedul Islam Khan


    We appreciate sharing your thoughts on this. At this moment, we only support the current version v5.6 and previous version v5.5.3 but not anymore older version of WordPress. You can find more information about this here




    I just happen to stumble across your question. It appears WP 5.5 was released on August 11, 2020. According to this link:

    Here’s the link to their full changelog:

    Scrolling down, the list I found version 14.7, released on August 5th, 2020; since that was the last update before WP 5.5, it is a pretty good chance that it will work with WP 5.4.

    That said, if you look at the changelog for 14.8, that one states the minimum version for WP is version 5.4. A few days after that, there was a bug fix, version 14.8.1. It seems reasonable to go with 14.7 or 14.8.1.

    I am not affiliated with Yoast SEO in any way other than I use their product. This is me just providing a logical guess.

    I hope this helps!

    Thread Starter Ov3rfly


    @mazedulislamkhan Thanks. After showing your information link to client, they decided to drop Yoast SEO in favour of a competitor who provides compatibility to WordPress 5.4.x and further back.

    @shazahm1hotmailcom Thanks for your insight.

    Plugin Support Michael Tina


    Hi @ov3rfly

    We understand you’ve gone with another SEO plugin and we totally respect that. We understand that some themes or plugins may not be compatible with newer versions of WordPress, and that would mean if you were to use WordPress 5.4 or older, that would mean requiring an older version of the Yoast SEO plugin as well.

    Staying at an older version of our plugin means it is less secure, and without the option to update, there is no opportunity to avail of the new features, bug fixes, and enhancements with each update we release. We are also unable to provide support for older versions of our plugin. We really do recommend staying up to date when possible, as it ensures the best performance for your website as a whole. Setting this to resolved.



    As the developer, it’s obviously your decision.

    But if someone really wants to get a specific backward-compatible version of the plugin, why not just provide this information instead of making them guess? Your clients sometimes really do know what’s best for them.

    Thread Starter Ov3rfly


    @mikes41720 FYI, after communicating your support strategy to more clients, we now dropped Yoast SEO at a total of 38 sites, more coming.

    Plugin Support Pcosta88



    We understand your desire to get support but at this time we only support issues related to v5.5.4 or v5.6 of WordPress. This guide explains more: So if you run into issues and you are on older versions of WordPress we are unable to provide support for it.

    While we do not keep a list of what versions of our plugins are compatible with what versions of WordPress (as we only support issues related to the newest release of WordPress and the one before it) you are welcomed to review our changelog: and cross reference it with the WordPress release to identify a release date and plugin which might work.

    You can then download it from our Github repository here

    Thread Starter Ov3rfly


    @pcosta88 Thanks for your response.

    .. we only support issues related to v5.5.4 or v5.6 of WordPress

    We were not aware that WordPress 5.5.4 is released, thanks for this information.

    Everything else you said has been posted already literally word by word by your support colleagues weeks ago and we already have carefully evaluated every link and communicated all the information to clients and already are in the process to drop Yoast SEO and switch to a competitor plugin that is able to support compatibility to further back WordPress branches.

    Our only desire was to know which Yoast SEO version is compatible to WordPress 5.4.x, and while we got no answer for this question, we still are glad we asked as the outcome was very helpful to adjust our selection of recommended plugins.

    Plugin Support Pcosta88



    While we are unable to give specifics as we have not tested all Yoast SEO Premium versions with all the different WordPress versions, if you go with 5.4 of WordPress which was released on March 3, 2020 the Yoast plugin versions starting v13.2 which you can find here would the best place to start.

    You will likely need to trial and experimentation to find the right plugin to match the right version of WordPress you are using. You may also need to use those previous links to cross-reference when plugins and WordPress core was released.

    We hope that helps!

    • This reply was modified 5 months ago by Pcosta88.
    Plugin Support devnihil


    We are going ahead and marking this issue as resolved due to inactivity. If you require any further assistance please create a new issue.

    Thread Starter Ov3rfly


    The issue is not resolved, “likely need to trial and experimentation” is not an answer to a question for a version number.

    Just faced the similar scenario. The last supported version is 15.4. I checked from their SVN.

Viewing 14 replies - 1 through 14 (of 14 total)
  • You must be logged in to reply to this topic.