Support » Plugin: Yoast SEO » Which image on opengraph?

  • Resolved wongpk

    (@wongpk)


    I setup the Social tab information for both Facebook and Twitter. However, when shared it is still showing Featured Image. Is there a way to actually show the image that is setup on the Social tab?

    Currently I’m using other plugins for the Facebook share, but I tried to use Yoast SEO social tab whenever there is update, it’s been 3 updates and it’s still not showing up what is setup.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Support devnihil

    (@devnihil)

    @wongpk We’re sorry to hear you are experiencing difficulties in getting your link preview to show the specified image on Facebook.

    If you are seeing unexpected behavior or appearance for one of your site’s social previews when sharing it on social media, this can be caused by the social media site caching old metadata for that page. This is why you may not immediately see the new values you set up for the page reflected in the page’s preview when you share it (image, title, description, etc).

    To resolve this, we would first recommend to try checking your page’s link using Facebook’s Sharing Debugger tool located at https://developers.facebook.com/tools/debug/sharing/. Can you please try running the Facebook Sharing Debugger on the page you are experiencing the issue on, and under ‘When and how we last scraped the URL’ clicking the ‘Scrape Again’ option and letting us know whether this resolves the issue? The ‘Scrape Again’ option will force Facebook to update it’s cache for your page’s link.

    Please note that to successfully update the cache it may require re-scraping your page several times as whether the page’s data can be read may take several requests between Facebook and the server your website is hosted on. Also, this guide includes more information on this and explains in detail how to do this: https://kb.yoast.com/kb/facebook-sharing-updated-details/

    If after re-scraping the page’s metadata you are still not seeing the correct image, can you please provide us with an example URL of where the issue is occurring so that we can check into this further?

    Thread Starter wongpk

    (@wongpk)

    Hi, that is what I tried each time there is an update on the plugin. When I disable the other sharing plugin, the Yoast still get Featured Image instead of the image upload for the Social tab.

    I clear the site cache, remove the other plugin and tested on the debugger site. Even scrape again still come up with Featured Image.

    I’m sorry, not really convenient on the URL address, I will double check more into it.

    Thanks!

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Which image on opengraph?’ is closed to new replies.