Support » Fixing WordPress » Where has the nice editor gone?

  • Resolved kouya

    (@kouya)


    Hello, I’m running WP 2.0 (and very happy with it) but somehow over the last couple of weeks the rather good editor that WP 2.0 was using to write posts seems to have gone away and has been replaced with the editor which was there in earlier versions of WP. The only thinng I can think has happened was that I messed up a plugin, while I was doing things with Lazyest gallery, but I’m not sure that this is the issue. Any ideas anyone?

Viewing 15 replies - 1 through 15 (of 25 total)
  • In the Users admin panel, near the bottom of your profile, there is a check-box for using the rich editor, make sure that’s checked.

    It is checked, but that doesn’t seem to be the answer. Thanks though. I’ve also got the rich editor checked on the options/write page.

    I am having exactly the same problem, I also started my WP blog about two weeks ago, used the visual rich editor editor with no problmes then a couple of hours ago it just stopped being available. I have it checked as the default for all users in Options/Write and in my User profile. I haven’t added any plugins since I last used it and the only thing I have changed was a blockquote format in the style sheet (taking that out does not make the text editor return to visual rich editor).
    I am using Firefox to view my admin panel but I have changed nothing in that setup for weeks. Totally baffled and would rather like to get the thing back as I am much more comfortable using that. Hope someone can help me and kouya!

    Hmmm, I think it’s a little strange – have you tried it in a different browser? What version of WP are you on? If you’re not using WordPress 2.0.1, maybe try upgrading and see if that solves it.

    If you can post anymore details, that may be helpful.

    Good luck,
    Michael.

    I have tried using IE, no effect. As far as I am aware I am using 2.0 so I may try the upgrade tomorrow.
    Been thinking hard, the only admin actions I remember carrying out since I last saw it was a database backup and as I said, modifying the css, adding format for blockquote oh and also added to the header.php to have a favicon. I tried undoing all of these changes and that had no effect. I removed all but the plugins my default insatllation gave me and that had no effect. I am wondering if it is a mysql error but I don’t know enough about it to say…grasping at straws really on that one.

    update, just checked other parts of my site and my gallery2 has failed. Might be related.

    At this point, I would if it were me check with my host to see if they “upgraded” something – like apache, php, mysql….

    thats my thought, or possibly maintaince of some sort, although the gallery is back now…visual editor isn’t. Think I’ll leave it for now and see what it is doing tomorrow. If it gets resolved I’ll post. Thanks for your suggestions!

    Yes, please post back whichever – the next guy along may need to know!

    i know the rich visual editor is not fully functional through opera 8.52 (regardless of whether the user has checked the appropriate checkbox in ‘users’). here’s a screen capture comparing posting through opera and posting through IE6. these are identical posts. browser post examples

    Thanks for the replies to this post. I normally use firefox, but I’ve also tried to post using Opera and IE and in neither case is the rich editor there. I’ll check with my server (on Monday when they wake up) to see if they have changed anything. Any other thoughts would be gladly accepted.

    Ok, upgraded to WP 2.01 and that has not made any difference. I am going to contact my webhost and ask if they have changed the hosting environment at all.

    [edit]installed a second WP blog to see how it was. Visual editor is present and working which suggests it is something I have done or that is “broken” in my original blog.

    Have you installed anything new on your local computer? Some of the “security suite” software (like symantec, for example) have some over aggressive javascript blockers that might do this. If you have something like that, try disabling it for a moment and see if that helps.

    I only suggest this as it seems to happen with any browser on your computer.

    I checked that just now, thank you for the suggestion, I have made sure my firewall and my virus killer are not blocking scripts from my blog. Also see my edit above. I will also try editing from another IP address tomorrow to see if that has an effect.

    Ah, ok. Do the two blogs have all the same plugins installed?

Viewing 15 replies - 1 through 15 (of 25 total)
  • The topic ‘Where has the nice editor gone?’ is closed to new replies.