Support » Plugin: WP Redis » Where exactly to place cache credentials?

  • Resolved lvnt

    (@lvnt)


    Unable to connect redis db at redislabs.com

    I have a fresh installed Bitnami WP multisite on AWS, runs with a few basic plugins and with 1 common db which serves to 4 subdomains.

    I feel that I am placing the “cache credentials” on a wrong line in the config.php file.
    Because when I install&activate the old redis plugin, which I am used to, it can establish the connection to the remote db.
    Can I get a helping hand here?

    – Where to put code credentials?
    – Is there even a correct line? Or any line should have been okay?
    I can somehow read codes and understand logic but it seems like I’m still far from executing them by myself.

    THINGS I’VE TRIED

    First, Wp-Redis plugin couldn’t work when I placed its “cache credentials” just above the ” /* That’s all, stop editing! Happy blogging. */ ”
    Then I tried another spot under where my traditional config.php database credentials are.. Again, couldn’t get the heartbeat !

    King Regards

    If you let me I have another queston, too..
    As far as I know, WP Redis plugin falls-back to local db if it can’t establish connection to redisdb. I believe you explain this feature in object-cache.php; between 1057th to 1072nd lines.
    I’d like to learn which line on which file executes this event, in case that in the future I happen to change my local db port(or host or etc).

    • This topic was modified 5 months, 3 weeks ago by  lvnt.
    • This topic was modified 5 months, 3 weeks ago by  lvnt.
    • This topic was modified 5 months, 3 weeks ago by  lvnt.
    • This topic was modified 5 months, 3 weeks ago by  lvnt. Reason: Grammer correction, nothing serious :)
Viewing 1 replies (of 1 total)
  • Redis example creds:

    $redis_server = array(
         'host'     => '127.0.0.1',
         'port'     => 6379,
         'auth'     => '12345',
         'database' => 0,
     );

    Should be above:

    /* That’s all, stop editing! Happy blogging. */

    What is the exact error that you are getting?

    • This reply was modified 5 months, 3 weeks ago by  Carl Alberto.
Viewing 1 replies (of 1 total)
  • You must be logged in to reply to this topic.