WordPress.org

Forums

Where else do I change 1500 KB limit in Theme Uploading in 3.3 (5 posts)

  1. teneagles
    Member
    Posted 3 years ago #

    I was uploading a theme of 1557k and got the message that there was a limit to the uploads of 1500k. I came here and search and found the posts recommending I ask my site space provider to have the php.ini upload limits to be changed up to 32M. I found then it was already set to 64M.

    Knowing that the PHP setting were not the problem, I then scanned the code for a hard coded limit number (1500), which I found in three files.

    1. schema.php had a line ... fileupload_maxk' => 1500
    2. ms.php and msfunctions.php had lines ... ('fileupload_maxk, 1500)

    I replaced the 1500 in each with 3000, save the files and retried. I STILL get the following error: "This file is too big. Files must be less than 1500 KB in size. Back", even though I can find no more instances of the number 1500 in any file of the wordpress installed in my section on that server.

    So can ANYONE tell me why I get a limit error of 1500 still?

    If this were html, I wold think there there is a cached version of the file loading, but it is php, and I have erased the browser cache..

  2. rotrif
    Member
    Posted 3 years ago #

    Go to cPanel, select phpMyAdmin and select your database, button at the top in the left. After you select the database at the appear list click to wp_sitemeta and now select edit fileupload_maxk and modified the 1500 limit and press Go. Thats it.

  3. rpwilso
    Member
    Posted 2 years ago #

    THANK YOU rotrif. I too had this issue. This absolutely worked. I appreciate your post!

  4. Store Locator Plus
    Member
    Posted 2 years ago #

    There is a setting in the WordPress admin panel "maximum upload file size". This applies to theme files uploaded via "Theme / Upload".

    In WPMU it is under the main "Network Admin / Network Settings" page.

    You can edit this from the web interface via an admin login WITHOUT having to get into the MySQL interface directly via phpMyAdmin or command line.

  5. Matt Fraser
    Member
    Posted 2 years ago #

    Rotrif,

    Thanks a bunch as I had this issue as well and it worked great. Thanks for posting.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.