Support » Plugin: Enhanced Media Library » Where do i find the NUMBER for desired Media Category

  • Hello,

    I am thrilled to have found EML and looking forward to testing it. But the instructions stop right where the most critical item is required.

    For example, your instructions gives the following shortcode example:

    [gallery media_category="5" category="2" limit="10" monthnum="8" year="2016" orderby="title" order="DESC"]

    But where do I find the media_category number associated with my desired category?

    Currently I have a single media category and have five photos assigned to it.

    When i click to edit the media category, I get the following URL:

    .../wp-admin/term.php?taxonomy=media_category&tag_ID=129&post_type=attachment&wp_http_referer=%2Fwp-admin%2Fedit-tags.php%3Ftaxonomy%3Dmedia_category%26post_type%3Dattachment

    The only likely number I see in the above link is tag_ID=129. So is my media category number 129? That’s not working for me, when I use the following shortcode inside a post.

    [gallery media_category="129" limit="10" orderby="title" order="DESC"]

    Please explain.

    And is there a way to just use the name of the media category instead of hunt down the media category number?

    And why does your example also has a category=”2″ item? If I just want to display some thumbs inside a post, don’t I just need the media_category number?

    Tried to search the older support posts but search tool returns hundreds of links related to many other plugins.

Viewing 14 replies - 1 through 14 (of 14 total)
  • I used this plugin https://wordpress.org/plugins/reveal-ids-for-wp-admin-25/ to reveal the ID and yes, in above example, the ID of my media_category is 129.

    So my question is still why the following shortcode doesn’t do anything. I have 5 images assigned to it.

    [gallery media_category="129" limit="10" orderby="title" order="DESC"]

    Thank you.

    Hello, when I use the above shortcode, i do see the thumbs of the 5 photos that have that media category in the VISIBLE tab of the post edit field.

    screenshot

    But when I save and preview the post, nothing appears: https://goo.gl/mSUlwR

    Could this be related to my theme?

    Still waiting for your response more than 2 weeks later. I don’t know how you expect people count on your product if questions are not answered.

    Moderator Jan Dembowski

    (@jdembowski)

    Brute Squad and Volunteer Moderator

    @polaatx Please do not create duplicate topics for the same thing. Those are closed or deleted when found. I’ve removed your other topic.

    I can’t get a response! What am I supposed to do? I am waiting and waiting for help and when I don’t get a response, I am trying to get it somewhere else!

    Plugin Author webbistro

    (@webbistro)

    Hello @polaatx,

    I apologize deeply for ignoring your questions! I hope that my answers can still be helpful for you today.

    (1) Your assumption about tag_ID=129 is correct. And Reveal IDs is the great choice to find out IDs for your media categories in a convenient way.

    (2) The shortcode will not work until you explicitly activate the feature on Settings > Media > Media Library (tab). Set “Enhanced media shortcodes” to make it work.

    (3) At the moment there is no way to use the name of the media category instead of the ID, we will add this to the upcoming versions.

    (4) You can use category=”2″ along with or instead of media_category=”129″ if you wish to filter images in your gallery by post categories as well. It will work if you assigned post categories to the media library first.

    (5) If you see a correct set of images on the back-end and the wrong one on the front-end, then yes, it can be related to your theme and page templates. You can try to activate one of WordPress “twenties” to check if it works.

    Again, sorry for my silence. Please feel free to ask your questions. I will respond in a few hours from now.

    Thank you for your patience!

    Best,
    -Nadia

    • This reply was modified 1 year, 6 months ago by  webbistro.

    Hello Nadia, thank you for your reply. I had turned on “Enhanced media shortcodes” in Media Settings before. But it still does not work, even though I do see the gallery in VISUAL tab of the post edit field.

    screenshot

    As explained before, this is my code:[gallery orderby="title" order="DESC" media_category="129" limit="10" link="file"]

    This is the published post: https://goo.gl/mSUlwR

    Do you have any other ideas on why it’s not working?

    • This reply was modified 1 year, 6 months ago by  Ali.T..
    Plugin Author webbistro

    (@webbistro)

    Hello @polaatx,

    Sorry again for the delay.

    I see no gallery following your link, neither do you? It looks like your page template does not “understand” gallery shortcode. Can you please temporarily change your theme to one of WordPress “twenties” to check if you can see the gallery on the same page in this case?

    Best,
    -Nadia

    • This reply was modified 1 year, 6 months ago by  webbistro.
    • This reply was modified 1 year, 6 months ago by  webbistro.

    Hello, No, I don’t see a gallery – even though I do see the gallery in the visual pane of the edit it page. Refer to screenshot I posted earlier.

    Per your instructions, I changed the theme temporarily to Twenty Fifteen. Still seeing no gallery:

    • This reply was modified 1 year, 6 months ago by  Ali.T..
    Plugin Author webbistro

    (@webbistro)

    Hello @polaatx,

    Thank you. Can you please deactivate all other plugins (temporarily) to see if some of them affect the gallery? Also, can you please to post a screenshot of your browser developer tools (push F12 to show/hide it)?

    Another thing, maybe you are willing to provide an access to your website admin in order I was able to investigate the issue? You can contact me privately at wpuxsolutions@gmail.com

    Best,
    -Nadia

    Hi Nadia, there is someone working on the site so can’t disable any plugins right now.

    By screenshot of developer tools, do you mean something like this? https://ibb.co/fLBEDF

    You know the page is online: https://goo.gl/mSUlwR

    I looked at it in Mozilla and same results. No pics.

    Plugin Author webbistro

    (@webbistro)

    Hi @polaatx,

    Thank you for the screenshot! It shows that we have a JS error. Can you please post the one of the “Console” tab. Right now it shows “Elements” tab (on the top panel underlined in blue).

    Best,
    -Nadia

    • This reply was modified 1 year, 6 months ago by  webbistro.

    Hi Nadia,

    Here’s a shot of the console tab: https://ibb.co/kkfPVv

    Plugin Author webbistro

    (@webbistro)

    Thanks! It’s an error of a chrome extension… Since you get the same issue in the other browser it’s most likely unrelated to it.

    To continue investigation we have to make sure that other plugin or theme does not affect it. Please let me know what is the result of deactivating other plugins when you have a chance to check this.

    Best,
    -Nadia

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Where do i find the NUMBER for desired Media Category’ is closed to new replies.