WordPress.org

Ready to get started?Download WordPress

Forums

Where did my home page go? (33 posts)

  1. maureenvs
    Member
    Posted 4 years ago #

    When I go to my main URL, I get a message "Search returned 0 results" and don't see where that page is coming from in my admin.

    It looks like it's my homepage but it's not the same home page that's in my pages?? Thanks!

    http://www.blissfestkc.com/

  2. Jonas Grumby
    Member
    Posted 4 years ago #

    Does it happen if you switch to the Default theme?

  3. maureenvs
    Member
    Posted 4 years ago #

    I'll try that but I hope I don't lose all my settings. I tried adding a home page, and now the url goes to that page but I have two home page tabs.

  4. maureenvs
    Member
    Posted 4 years ago #

    I got fatal error?? Yikes!

  5. Jonas Grumby
    Member
    Posted 4 years ago #

    That's much better. There's a way to get rid of that.

    http://codex.wordpress.org/Good_Navigation_Links#Pages

  6. Jonas Grumby
    Member
    Posted 4 years ago #

    Somewhere you have a <br (unclosed line break tag) in your code.

  7. Jonas Grumby
    Member
    Posted 4 years ago #

    Did you edit any of the Default theme files?

  8. maureenvs
    Member
    Posted 4 years ago #

    No idea what I'm doing with this, can you explain?

  9. Jonas Grumby
    Member
    Posted 4 years ago #

    This is from your source code:

    <div id="header" role="banner">
    	<div id="headerimg">
    
    		<h1><a href="<br />
  10. maureenvs
    Member
    Posted 4 years ago #

    No, did not use the default.

  11. Jonas Grumby
    Member
    Posted 4 years ago #

    Do you know how to use FTP? If you re-upload the Default theme (a fresh copy) it will probably fix the fatal error.

  12. maureenvs
    Member
    Posted 4 years ago #

    I am using cyberduck. I'll check it....

  13. Jonas Grumby
    Member
    Posted 4 years ago #

    Right now it looks like your site is set to display the Default theme but there is some bad code in the header.php file. Did you or anyone else try to edit that file?

  14. maureenvs
    Member
    Posted 4 years ago #

    I see "default" in the theme folder, but not sure how to upload it. When I use premium theme, I drop it in and it uploads automatically.

  15. Jonas Grumby
    Member
    Posted 4 years ago #

    Are you seeing that with FTP software? If you have an unedited copy of the Default theme header.php file on your hard drive, you can go to the wp-content/themes/default folder and upload it to replace the corrupted one that is there.

  16. maureenvs
    Member
    Posted 4 years ago #

    It's saying, "listing directory failed"
    Is there a way to download a clean copy of default and drop it into my ftp?

  17. Jonas Grumby
    Member
    Posted 4 years ago #

    You can also log into your admin and go to the theme editor and copy & paste it in but make sure you are copying from a plain text editor and make sure you are editing the right file (of course).

  18. Jonas Grumby
    Member
    Posted 4 years ago #

    Yes you can download the zip file at

    http://wordpress.org/extend/themes/default

  19. maureenvs
    Member
    Posted 4 years ago #

    What do I copy and paste and where? I don't have the original anything, it seems.

  20. maureenvs
    Member
    Posted 4 years ago #

    I downloaded and dropped into my blissfestkc theme folder, then uploaded. It still says, "error."

  21. Jonas Grumby
    Member
    Posted 4 years ago #

    You would have to download the theme, unzip it and then upload it to replace the one in wp-content/themes/default

    I just tried to edit the Default header.php of my site via admin and it said Sorry, that file cannot be edited., so I guess you can't do it that way after all.

    You can also go back to your old theme or go to a completely different theme and that should get your site back up. Try that and post back. Your Default theme does seem to be messed up but that is not the original problem.

  22. Jonas Grumby
    Member
    Posted 4 years ago #

    Di you unzip it and upload the header.php file to wp-content/themes/default/?

  23. bobversus
    Member
    Posted 4 years ago #

    Hi,

    I have a hosted blog (via myfreeola) using wordpress.

    I accidentally changed my URL in settings-general to the wrong address, now it's broken!

    I changed it from:

    http://www.bobversus.com

    to

    http://www.bobversus.com/charity

    I wanted to redirect, making the charity page my home page but now nothing works and it won't let me into wp-admin.

    PLEASE HELP! How do I reset things back to normal??

  24. maureenvs
    Member
    Posted 4 years ago #

    I changed it back but didn't see your last post:
    Di you unzip it and upload the header.php file to wp-content/themes/default/?

    I can try that.

  25. maureenvs
    Member
    Posted 4 years ago #

    So I just upload the one file "header.php" and not the whole default file, right?

  26. Jonas Grumby
    Member
    Posted 4 years ago #

    @bobversus that is a totally unrelated question and should be in a new thread to get the proper attention, but read this:

    Changing The Site URL

  27. Jonas Grumby
    Member
    Posted 4 years ago #

    Looks like the site is working fine now. Yes you should be able to upload just the header.php file to replace the old one but you can also upload all of the files in the folder. It wouldn't hurt anything as long as you are putting them into the right folder on the server. But, since everything seems to be fine now, you may want to leave it alone.

  28. maureenvs
    Member
    Posted 4 years ago #

    I changed it back to default to give it one more try but didn't work. So, I'll change it back to the other theme, and guess I just delete one of the two "home" tabs. Thank you so much for your help!!!

  29. maureenvs
    Member
    Posted 4 years ago #

    One more note...
    When I changed it back, I deleted the home page as it was the only way that only one tab appeared. But, since there is no real way to edit it now (it does not show up in pages) there is no content.

    Now I don't remember how I put content on that page. I'm frazzled and need to step away from my computer for a bit. Maybe it will magically happen when I return. :)

  30. Jonas Grumby
    Member
    Posted 4 years ago #

    Ok, yes if you deleted your home page then it would make sense that it wouldn't come up when you go to the home URL. I'm not sure if Settings > Reading magically knows that the page is gone. You would have to create a page and assign it as the static home page in Settings > Reading. Looks like you have it all fixed now though.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.