Support » Plugin: WordPress Email Marketing Plugin - WP Email Capture » Where are the email addresses?

  • Resolved mburke79

    (@mburke79)


    Hi!

    Ok here is where I am at:
    -plugin installed & activated
    -I’m using Postman SMTP and its configured correctly
    -I created the required pages

    In testing:
    -I enter a name & email address and click send
    -I am correctly rerouted to the sign-up page
    -I correctly receive an email with an address confirmation link
    -I click the link and I am correctly rerouted to the confirmation page

    The problem is the confirmed name/email is not appearing in the “Members” list in the settings, and when I click the “Download CSV” button in the settings, the confirmed email address is not there! All I see is “Name” and “Email” in the table. Any idea why the names/addresses are not appearing in the Members list or the CSV file?

    Thanks!

    • This topic was modified 1 year, 1 month ago by  mburke79. Reason: additional information

    The page I need help with: [log in to see the link]

Viewing 8 replies - 16 through 23 (of 23 total)
  • Plugin Author Rhys Wynne

    (@rhyswynne)

    Hi Mike,

    Thanks for that 🙂 – good to hear! I do try and be helpful!

    Right. I’m going to try and make you create the table manually. I’m actually randomly wanting an error for this, as I feel like something with the host is not liking that SQL query. What I’m not sure. So first of all…. PLEASE MAKE A BACKUP.

    Here’s instructions:-

    • Make sure you are backed up and have the database selected.
    • Click on the SQL tab
    • Copy & paste this from the grey box in. Make sure it’s correct and you select everything (on my screen there is a long line so you may need to scroll sideways).
    CREATE TABLE wexlRFZwp_email_capture_registered_members (
    id INT( 255 ) NOT NULL AUTO_INCREMENT ,
    name TINYTEXT NOT NULL ,
    email TEXT NOT NULL ,
    date DATETIME NOT NULL DEFAULT CURRENT_TIMESTAMP, 
    UNIQUE KEY id (id)) DEFAULT CHARACTER SET utf8mb4 COLLATE utf8mb4_unicode_520_ci 

    Then let me know the result of that query. Thanks!

    rondigi: If you read this, these instructions won’t work for you.

    Thanks!

    Rhys

    • This reply was modified 1 year, 1 month ago by  Rhys Wynne.
    • This reply was modified 1 year, 1 month ago by  Rhys Wynne.
    Plugin Author Rhys Wynne

    (@rhyswynne)

    Ah!

    Right. Got it.

    What is occurring is that the server you are on has MySQL 5.5 or below.

    WordPress’ minimum version is 5.6. WP Email Capture uses a function in 5.6 to create the table. In order for the plugin to work you should ask your host to update MySQL to 5.6. Once done, you should change the option again to force a table update.

    Hope that helps. Let me know how you get on!

    Rhys

    Ok. I love 1&1 but sometimes they frustrate me. They won’t support a newer version than 5.5 at this time.

    So. Do you have any ideas about other plugins that serve the same functionality as yours?

    Also – I’m submitting my 5-star rating now.

    Hey Rhys,
    Thanks for listening!
    After upgrading from mysql to version 5.6.33 I was able to create the table “wp_email_capture_registered_members”.
    Despite this, when confirming the email received, it still does not record the name and email in the new table. Please see the image below:
    http://bahiasolucoes.com.br/ronaldo/images/wp-email.png
    Here the structure created:
    http://bahiasolucoes.com.br/ronaldo/images/wp-email2.png

    Plugin Author Rhys Wynne

    (@rhyswynne)

    Sorry for the delay in responding, long day yesterday.

    @mburke79: To be honest, if 1and1 are going to not upgrade, you’re probably better with voting with your feet. 5.5 is below the minimum requirements for WordPress and as time goes on you’re going to hit problems again and again. You’re far better off just moving host. Have a look at the hosts here – https://wordpress.org/hosting/ – I use Siteground and have no problems with it.

    @rondigi: The best course of action for you is to let the plugin recreate the table for you. I think the table name is incorrect.

    1. Do a backup.
    2. Go to [yourdomainname.com]/wp-admin/options.php (you have to type it into the address bar).
    3. Search for wp_email_capture_db_version.
    4. Change the 3.5 to another number (say 3.4).
    5. Save and try again.

    Thanks!

    Rhys

    Perfect! I changed it from 3.5 to 3.4, saved it and it works now. The member appears and exports to excel.
    Thanks again for the feedback.
    5 stars!!!!!

    Plugin Author Rhys Wynne

    (@rhyswynne)

    No problem 🙂

    Marking this as done. I’ll introduce a check on installation for MySQL.

Viewing 8 replies - 16 through 23 (of 23 total)
  • The topic ‘Where are the email addresses?’ is closed to new replies.