Support » Fixing WordPress » When writing a new post rnrna (or similar) appears at line breaks?

  • Weird, every time I try and post something rnrna shows up within line breaks an example would be

    likely you are:rnrna. My momrnb. Read about us onlinernc. Heard about us through a friend or,rnd. Googled “clean” (or something like that)rnrnIn

    when it should look like

    it’s likely you are:

    a. My mom
    b. Read about us online
    c. Heard about us through a friend or,
    d. Googled “clean” (or something like that)

    I even tried spacing it through HTML and nothing using <p>/
    tags. Does anyone know a fix? Thanks


Viewing 6 replies - 1 through 6 (of 6 total)
  • I had the same problem. I actually did this on every page of my blog by accident. The culprit was Synonymizer plugin. Although it wasnt selected for the page I was editing, it changed the code. When it happened I removed the plugin and tested a few other pages and they worked fine again. I dont think that Synonymizer is designed for 2.5, but their site was down so I couldnt check.

    Hope this helps. If you dont have this plugin, deactivate your plugins one by one and edit a post and save it to see if the problem is still there.

    I also have this problem, but don’t have the Synonymizer plugin. Did you find the answer??

    I’ve set up several WordPress sites with no problems, usually 2.6 under Windows and Apache. Just my latest site is giving me this effect and I’m not sure where the carriage return line feed are being stripped of their slashes.

    I STILL havent found a fix for this, its driving me absolutely crazy. Help Please!

    Have you disabled all plugins to see if the problem goes away? If it does, then a plugin is causing it.

    I have the same problem since about June/July – I think it’s a bug in PHP 5.2.6, I reported in through the wordpress bug tracker:

    You can solve the problem manually by replacing all occurences of “$wpdb->escape” with “addslashes” in the source code (as far as I noticed the $wpdb->escape function only appears in wp-includes/functions.php and wp-includes/formatting.php, so it’s not even that much work). Not really a great solution, but at least it works for the time being.

    In case anyone is using the synonymizer plugin and is having this issue the problem is that the plugin calls the mysql_escape_string function when returning post content. After removing this from the code it works fine.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘When writing a new post rnrna (or similar) appears at line breaks?’ is closed to new replies.