Support » Plugin: Conversational Forms for ChatBot » When updating to PHP8 I get error

  • Resolved Per Olsson

    (@styrketrappan)


    When I try to upgrade to PHP8 I get this error message:

    Fatal error: Unparenthesized a ? b : c ? d : e is not supported. Use either (a ? b : c) ? d : e or a ? b : (c ? d : e) in /home/xxxxxx/public_html/wp-content/plugins/conversational-forms/classes/core.php on line 3692

    Is there some workaround I can do or will I need to be patient until you send out an update for PHP8? ๐Ÿ™‚

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author QuantumCloud

    (@quantumcloud)

    We have not released PHP 8 compatible version yet. We are actively working on it. Should be ready by early next week.

    Thanks

    Thread Starter Per Olsson

    (@styrketrappan)

    Thanks a bunch for so quick reply! I’ll be patient, I just did a test upgrade and it was several other plugins I use that also seem to have PHP issues.

    Plugin Author QuantumCloud

    (@quantumcloud)

    PHP 8 brings huge changes. More than 50% plugins and themes will break down at this stage. We suggest waiting a few more months before upgrading to PHP 8 in a production environment.

    Thanks

    Thread Starter Per Olsson

    (@styrketrappan)

    Ok, thanks for your input. Then I will surely wait if it is that many plugins that wont work! I use 46 plugins so that would be quite many support tickets to write, so I’ll wait a couple of months then ๐Ÿ™‚

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘When updating to PHP8 I get error’ is closed to new replies.