WordPress.org

Forums

SoundCloud Is Gold
[resolved] when the plugin is installed and active you cannot edit pages (11 posts)

  1. igor3063
    Member
    Posted 1 year ago #

    Hi,

    When SoundCloud Is Gold is installed and active on WordPress 3.9 you cannot edit pages. the pages seem to be blank on the back end but the content is there. I used 3.83 before and everything worked.

    the WP I tested is a multisite install and uses TinyMCE Advanced.

    can you fix this?

    thanks & best regards,

    Igor

    https://wordpress.org/plugins/soundcloud-is-gold/

  2. Chris Smith
    Member
    Posted 1 year ago #

    I have the same problem!

  3. igor3063
    Member
    Posted 1 year ago #

    Hi Chris,

    Thanks for the follow-up. I hope the author will fix it soon, I am trying another plugin but it does not fullfill my requirements.

    Regards,

    Igor

  4. jmikkola
    Member
    Posted 1 year ago #

    It's a conflict I found with WP Edit Pro (formerly ULTIMATE MCE PRO. If you deactivated Soundcloud,the WP EDIT PRO will function again.

    This is a Soundcloud issue that needs to be addressed by them and updated to work with 3.9. If I had to choose, I'd rather have my MCE than Soundcloud event though I have a lot of clips that use it.

  5. biberkopf
    Member
    Posted 1 year ago #

    Same problem here. Initially blamed it on qTranslate and mTranslate, but it turned out that SoundCLoud is Gold was the culprit. Really sorry to have to disable this plugin. Hoping for a quick solution to this bug. (I'm on WP3.9, not MS.)

  6. aovivo
    Member
    Posted 1 year ago #

    same here... i also noticed that i does not work on every smartphone either...

  7. dumboxp
    Member
    Posted 1 year ago #

    I have the same problem with the combination of WordPress 3.9 and Soundcloud is Gold Pugin 2.2.1. When Soundcloud Plugin is deactivated, the Visual Editor of WP works again.

    The JavaScript Console shows the following error:

    TypeError: tinymce.dom.Event.add is not a function

    in soundcloud-is-gold_editor.js line 124:

    tinymce.dom.Event.add(soundcloudIGold_editButton, 'mousedown', function(e) {
      var ed = tinyMCE.activeEditor;
      ed.windowManager.bookmark = ed.selection.getBookmark('simple');
      ed.execCommand("soundcloud_Is_Gold");
    });

    It seems that the new version of TinyMCE 4.x used in WP 3.9 does not support tinymce.dom.Event.add of Soundcloud is Gold Plugin any more. (see http://www.tinymce.com/wiki.php/api4:namespace.tinymce.dom)

  8. realtm
    Member
    Plugin Author

    Posted 1 year ago #

    Hi everyone,

    version 2.2.2 should fix that bug, it's just doing what Mat Lip is doing, I also fixed the insert shortcode button.

    This was a quick fix to keep the plugin going. I will have to work on it later, but I don't have much time on my hands.

    If you like this free plugin, remember you can Tweet about it (#soundcloudisgold @mighty_mess), rate it here or donate.

    Cheers

  9. igor3063
    Member
    Posted 1 year ago #

    Hi Thomas,

    Thanks for fixing this, I can now edit pages again when Soundcloud is Gold is active. Unfortunately, when I try using the plugin via the WYSIWYG editor (i.e. Add media, Soundcloud is Gold etc) and view the page I get the following error message:

    url parameter is not a valid SoundCloud URL. Learn more about using SoundCloud players.

    I hope you can fix this.

    Thanks and Best Regards,

    Igor

  10. Chris Smith
    Member
    Posted 1 year ago #

    all ok. perfect. thanx

  11. igor3063
    Member
    Posted 1 year ago #

    so it should work? or should i just wait a while? thanks...

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • SoundCloud Is Gold
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic