Support » Fixing WordPress » When switching the active theme to twentytwenty, a site failure occurred.

  • languageservicesco

    (@languageservicesco)


    Hi,
    The full error message is: “When switching the active theme to twentytwenty, a site failure occurred. Because of this we reverted the theme to the one you used previously.”

    There are a few posts on the web about this, but I found none that finished successfully. I was having frequent HTML error 500 messages, but in every case, when I refreshed the page it would display perfectly. So I installed the Health Check plugin and activated it. That is when I start getting the above error message if I try to use anything other than the default theme.

    Presumably it can’t be a plugin as they are all deactivated. On the other hand it isn’t an individual theme, so I am at a loss what to do next. Maybe re-install the latest version (5.8.2)? It is a development site that I have come back to after a while, so I can’t really say when this started.

    Thanks in advance.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Moderator Steven Stern (sterndata)

    (@sterndata)

    Forum Moderator

    >> . Maybe re-install the latest version (5.8.2)? <<

    Why not? It’s a one-button thing from dashboard->updates. 500 errors that come and go are rarely a WP issue, as usually once something is broken, it stays broken. That speaks more to intermittent resource issues on the host.

    The next time you get a 500, se if you can find any errors in the log. Enable wp_debug and wp_debug_log and after an error, look at wp-content/debug.log to see if anything gets logged there. https://wordpress.org/support/article/debugging-in-wordpress/

    Thread Starter languageservicesco

    (@languageservicesco)

    Hi Steve,

    Thanks for your response. I did the re-install and so far there have been no more 500s. It was odd that refresh in the browser toolbar always brought up the right page, but reload on the error 500 page never worked.

    Either way, it appears to be working now.

    Thanks again
    Kevin

    Thread Starter languageservicesco

    (@languageservicesco)

    I spoke too soon. It has happened a few times today. I set up debug as per those instructions, but no log file has been generated. I copied and pasted the code and put it in the right place, so I am trying to see what I might have done wrong.

    I will post again if I get the debug working.

    Thread Starter languageservicesco

    (@languageservicesco)

    I found the problem. There was a line above where I pasted the code that was setting debug to false, so I marked that out. Now I have what I suspect is the culprit, which might confirm what you said, Paul, about it not being WP. The message is:

    PHP Fatal error: Allowed memory size of 41943040 bytes exhausted (tried to allocate 28672 bytes) in /home/dh_y68iec/kevwes9.dreamhosters.com/wp-includes/pomo/streams.php on line 180

    I have no idea what that include is, but is this a WP problem or a site problem?

    Thread Starter languageservicesco

    (@languageservicesco)

    Following on from the last post, now I have that error message I have searched a bit and most solutions are talking about increasing memory for PHP to 256MB. I have done that, so let’s see. My only concern is that the live site doesn’t have this issue, but maybe the theme needs a bit more memory than the old one.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘When switching the active theme to twentytwenty, a site failure occurred.’ is closed to new replies.