Manual Related Posts
[resolved] When searching for related posts, no results show up anymore (4 posts)

  1. krystiank
    Posted 3 years ago #

    It basically stopped working. I disabled all teh plugins and nothing.
    When I want to add a related posts using a search box, I have no results.

    When I check for errors, it shows me something like:
    TypeError: c is undefined


  2. dave_meehan
    Posted 3 years ago #

    Yes, I'm getting this same problem, although doing some inspecting on the network requests, the search results are being returned, but not being inserted into the results panel.

  3. For what it's worth, version 17.17 is working just fine for me in this regard on 3.5.1.

    You said you've tried disabling all plugins - have you tried using a default theme?

  4. My research suggests that themes which return invalid XML during the search will run into this problem.

    The most likely cause on invalid XML coming back is that your theme (or a plugin) is adding whitespace to the top of the XML file.

    An easy way to debug is to just View Source of any page in your dashboard - is there whitespace at the top of the source code? If so, this is likely your problem.

    This can usually be addressed by removing the closing ?> tags from your theme's php files. If that alone doesn't do it, try to narrow down the source of your extra white space and resolve it.

    Plugin Author: This looks to be a somewhat common problem with people using your plugin. Perhaps you can apply some sort of trim() function to the XML that comes back before validating it?

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Manual Related Posts
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic