Support » Networking WordPress » when multi-site enabled, stie says database is broken

  • Resolved cb-rcw

    (@cb-rcw)


    I am working on enabling a multi-site. When I upload the new wp-config and .htaccess files, I go to log back in and it says that there is a broken database. I told it to go ahead and repair it, though nothing should have been wrong because it said the database was just fine moments before while it was a single site – and the following was the results:

    wp_1_posts: Table ‘db352522720.wp_1_posts’ doesn’t exist
    wp_1_comments: Table ‘db352522720.wp_1_comments’ doesn’t exist
    wp_1_links: Table ‘db352522720.wp_1_links’ doesn’t exist
    wp_1_options: Table ‘db352522720.wp_1_options’ doesn’t exist
    wp_1_postmeta: Table ‘db352522720.wp_1_postmeta’ doesn’t exist
    wp_1_terms: Table ‘db352522720.wp_1_terms’ doesn’t exist
    wp_1_term_taxonomy: Table ‘db352522720.wp_1_term_taxonomy’ doesn’t exist
    wp_1_term_relationships: Table ‘db352522720.wp_1_term_relationships’ doesn’t exist
    wp_1_commentmeta: Table ‘db352522720.wp_1_commentmeta’ doesn’t exist

    Any ideas? I keep hitting weird walls while trying to enable the multi-site on my domain.

    Please help! Andrea_r has been helping me on another forum, but I thought this was a different issue, so should have it’s own thread.

    I look forward to hearing your thoughts and ideas!

Viewing 15 replies - 1 through 15 (of 28 total)
  • Andrea Rennick

    (@andrea_r)

    Customer Care at Copyblogger Media and Studiopress

    Something is tripping a flag that tells it it’s an upgraded mu install. in multisite from a single WP, there’s NO wp_1_ tables needed.

    I’ve yet to figure out what’s going on tho.

    Andrea Rennick

    (@andrea_r)

    Customer Care at Copyblogger Media and Studiopress

    just for giggles, what instructions are you following?

    Andrea Rennick

    (@andrea_r)

    Customer Care at Copyblogger Media and Studiopress

    I just did this on a test domain.
    I downloaded a fresh copy of WP 3.0.5.
    I used an empty database.
    I followed all the steps, in this case I did a subfolder install as I was in a subfolder.

    I did not get this error.

    everything works as expected, including the additional test site.

    What process in your steps is different than the one I just typed? And where are you hosted?

    Andrea Rennick

    (@andrea_r)

    Customer Care at Copyblogger Media and Studiopress

    followup:

    WHERE in wp-config.php did you put the lines that you get in the Network menu? at the bottom? IF so, that’s your problem.

    (and I did address this in the ebook)

    Andrea Rennick

    (@andrea_r)

    Customer Care at Copyblogger Media and Studiopress

    Found it.

    Note when you paste in the lines in wp-config, there are TWO that mention multisite.

    define(‘WP_ALLOW_MULTISITE’, true);
    define( ‘MULTISITE’, true );

    BOTH need to be there.

    Here is where I added in the wp-config:

    /**
     * WordPress Localized Language, defaults to English.
     *
     * Change this to localize WordPress.  A corresponding MO file for the chosen
     * language must be installed to wp-content/languages. For example, install
     * de.mo to wp-content/languages and set WPLANG to 'de' to enable German
     * language support.
     */
    define ('WPLANG', '');
    
    /**
     * For developers: WordPress debugging mode.
     *
     * Change this to true to enable the display of notices during development.
     * It is strongly recommended that plugin and theme developers use WP_DEBUG
     * in their development environments.
     */
    define('WP_DEBUG', false);
    
    define('WP_ALLOW_MULTISITE', true);
    
    define('WP_ALLOW_REPAIR', true);
    
    define( 'SUBDOMAIN_INSTALL', true );
    $base = '/';
    define( 'DOMAIN_CURRENT_SITE', 'ultimatehealthtrends.com' );
    define( 'PATH_CURRENT_SITE', '/' );
    define( 'SITE_ID_CURRENT_SITE', 1 );
    define( 'BLOG_ID_CURRENT_SITE', 1 );
    
    /* That's all, stop editing! Happy blogging. */
    
    /** Absolute path to the WordPress directory. */
    if ( !defined('ABSPATH') )
    	define('ABSPATH', dirname(__FILE__) . '/');
    
    /** Sets up WordPress vars and included files. */
    require_once(ABSPATH . 'wp-settings.php');

    As for following the directions, I tried this for installing with my tester site – and it setup alright – but when I added the new sites on there, they are broken as they try to go to site.com/subdirectory/wp-admin – which doesn’t exist…

    Note when you paste in the lines in wp-config, there are TWO that mention multisite.

    define(‘WP_ALLOW_MULTISITE’, true);
    define( ‘MULTISITE’, true );

    BOTH need to be there.

    I’m going to try this right now and let you know how it goes!

    Alright – I added the code. Now the site will load with its content, but I still can’t login to the backend. It errors out and says the page doesn’t exist.

    Andrea Rennick

    (@andrea_r)

    Customer Care at Copyblogger Media and Studiopress

    And none of your permalinks work either.

    This is related.

    you need to fix your htaccess file. If you pasted it exactly as instructed, then it is not being read. contact your webhost.

    Hello Andrea_r –

    I hope your weekend was nice. =)

    I looked at my .htaccess file and there was one line missing, so I added it and now it takes me to the login page no problem. However, when I attempt to login, it gives me an Error 500 – Internal server page when trying to go to the wp-admin folder.

    Do I still need to speak with the webhost to discuss the .htaccess file being read?

    Thank you for your help!

    Andrea Rennick

    (@andrea_r)

    Customer Care at Copyblogger Media and Studiopress

    Yes, you do.

    Alright… So, apparently, I needed to put a line in the .htaccess file to use php5. I can now get to my backend – yay! And I have the Super Admin section – yay!

    However, I have another problem – which I also had with the subdirectory test site I created. Creating the actual subsites…

    I’m doing it wrong or have to do it special maybe. Since I am with 1and1.com, I can’t create the wildcard subdomain. However, I have the five subdomains I need created and pointed to the main domain. But, after I try and create the subsites in the Super Admin section, if I try and go to the backend for that section, it errors out on me with a 404 Error – saying the page/section does not exist.

    *bangs head against wall* Eventually I have to get this right…right?

    Thank you for your assistance so far. I would be very grateful if you could help me with this also. Thank you so much for all your time!

    However, I have the five subdomains I need created and pointed to the main domain.

    Did you point it to the /public_html/ folder?

    Andrea Rennick

    (@andrea_r)

    Customer Care at Copyblogger Media and Studiopress

    Seriously, on a different host this woudl have been done 3 days ago.

Viewing 15 replies - 1 through 15 (of 28 total)
  • The topic ‘when multi-site enabled, stie says database is broken’ is closed to new replies.