Support » Plugin: Super Page Cache for Cloudflare » When in Logged In Mode front end still redirected to the original URL

  • Hello There,

    I’ve turned on the SEO redirect.
    But sometimes when I’m in logged-in mode and try to visit the front end, the cache buster URL is redirecting to the original URL rather than the cache buster URL.

    Any clue what is going on?

    Thanks in advance.

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • Thread Starter Saswata Baksi

    (@amsaswata)

    Update: When I cleared the browser cache & cookie, it worked, but I faced the issue two consecutive days, can you tell me what exactly happening and how can I avoid this from happening in future?

    Plugin Contributor iSaumya

    (@isaumya)

    As you said yourself this issue has happened due to an old cache and cookies in your browser. I generally have never faced such issues. If you do face issue like this again, try hard refreshing the page.

    Thread Starter Saswata Baksi

    (@amsaswata)

    Um, again I faced the SAME issue, I tried the hard refresh but still until I remove everything from the chrome cache then it’s working, here’s the video for your ref: https://www.loom.com/share/c342864f69d349ed8a27f9135fbcc228

    Thread Starter Saswata Baksi

    (@amsaswata)

    Update: When I check this and clear the data then again it’s working normally. But why is this thing happening?

    Plugin Contributor iSaumya

    (@isaumya)

    Hi, I can see that you clicked on the link while the page is still loading (that in in the chrome favicon is still showing loading state) – this might be the reason for that.

    As that cache nbuster is added via javascript to all the links when you are logged in so. Can you try waiting for the page to be fully loaded and then try?

    Alternatively, you can also use the worker mode which does not use any cache buster query string.

    Thread Starter Saswata Baksi

    (@amsaswata)

    As that cache buster is added via javascript to all the links when you are logged in so. Can you try waiting for the page to be fully loaded and then try?

    Nope, I don’t think it is, in general, I wait for the page to load fully. Also, it works in incognito, and when I cleared the browser cache, maybe somehow the browser cache the whole cache even in the logged-in mode.

    If I disable the “SEO REDIRECT” is there any issue? As I saw it already takes the main document in canacolization.

    Alternatively, you can also use the worker mode which does not use any cache buster query string.

    Is it capable of handling 30k visits/day?

    Thanks again for your responses, it is really appreciable.

    Plugin Contributor iSaumya

    (@isaumya)

    Hi,
    the worker can handle any amount of request but in the free plan of worker it can only handle 100,000 requests per day. Beyond that you need to pay some amount.

    Without the login details to check the site as a loggedin user it is impossible to check what is going on. Does disabling SEO Redirect fixed the problem?

    Thread Starter Saswata Baksi

    (@amsaswata)

    Without the login details to check the site as a logged in user it is impossible to check what is going on. Does disabling SEO Redirect fixed the problem?

    I can give you the access, but the problem is this is not happening all the time, sometimes it did some times not, I am trying to replicate the issue but unable to replicate it as of now.

    I have added this rule so that browser won’t cache the cache buster content for a longer time: https://prnt.sc/1wpcojt

    Don’t know if it is the case or not.

    I’ll update this thread if I found any clue so that you can replicate the same.

    Plugin Contributor iSaumya

    (@isaumya)

    You don’t need that rule as when that cache buster is present the cache control is set to no cache by the plugin. So, that page rule is useless. Same for the WP admin rule. You don’t need that. The plugin will automatically bypass cache for loggedin users. All you need is the 1 cache everything rule added by the plugin.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘When in Logged In Mode front end still redirected to the original URL’ is closed to new replies.