Support » Localhost Installs » when I try to run the /wp-admin/install.php I just get the txt shown below

  • Resolved blongley


    `when I try to run the /wp-admin/install.php I just get the txt shown below instead of running the Install Script:

    ?php /** * The base configurations of the WordPress. * * This file has the following configurations: MySQL settings, Table Prefix, * Secret Keys, WordPress Language, and ABSPATH. You can find more information * by visiting {@link Editing * wp-config.php} Codex page. You can get the MySQL settings from your web host. * * This file is used by the wp-config.php creation script during the * installation. You don’t have to use the web site, you can just copy this file * to “wp-config.php” and fill in the values. * * @package WordPress */ // ** MySQL settings – You can get this info from your web host ** // /** The name of the database for WordPress */ define(‘DB_NAME’, ‘kkwordpress’); /** MySQL database username */ define(‘DB_USER’, ‘kathykeane’); /** MySQL database password */ define(‘DB_PASSWORD’, ‘BKd626403’); /** MySQL hostname */ define(‘DB_HOST’, ‘’); /** Database Charset to use in creating database tables. */ define(‘DB_CHARSET’, ‘utf8’); /** The Database Collate type. Don’t change this if in doubt. */ define(‘DB_COLLATE’, ”); /**#@+ * Authentication Unique Keys and Salts. * * Change these to different unique phrases! * You can generate these using the {@link secret-key service} * You can change these at any point in time to invalidate all existing cookies. This will force all users to have to log in again. * * @since 2.6.0 */ define(‘AUTH_KEY’, ‘kmnsrDF7d.0^Gw>+#3{P,Jvy9efZFnCD5wf$W<)p:3gt-,S:4+_ZV(p%aXhJ5’); define(‘SECURE_AUTH_KEY’, ‘-0H0M#bU7}kwc+g9{o_@K$a#u/Hb5$C,$ RIA:*7znqoHO~cu%qqdj>4#y0Kde7'); define('LOGGED_IN_KEY', '~HH~%vLd|9W@6RywQjDEcR?b;{QMvYR*b]-1MV*Etg;Yvv)To5*ga^{]>YA<+ _L'); define('NONCE_KEY', '0o]c9+bxpG]=@;ffaJFw*_?XOz|4-cmPK&Rn4?-E9fHaw44HF+Hr4+vHBI4Q00%’); define(‘AUTH_SALT’, ‘(,RTi%.cM-D2Q%>?8K0e?#8K0$EJmzAWox!q&)[X:I=^x|Yy[!Rad c=?-7?fWn5’); define(‘SECURE_AUTH_SALT’, ‘%>2Ud2jr|[z9o4k,KRu[i3^{Y<:vuGK*u|S@WtuE1iz(#8t|uIk;L^3Rl=R~NP3%’); define(‘LOGGED_IN_SALT’, ‘8Nme[K~%5T[o_Taf?pWzZj>V6uMrG/vu&{xCI:*/;;=NOIRo_bzGB5R+(X3M9[1d’); define(‘NONCE_SALT’, ’12XTT[|QncZ0F>C(r+s+HvN>cX!/i|d.z+H]p}O]bi,YOg(,7R.X~SQC4ix+q^’); /**#@-*/ /** * WordPress Database Table prefix. * * You can have multiple installations in one database if you give each a unique * prefix. Only numbers, letters, and underscores please! */ $table_prefix = ‘wp_’; /** * WordPress Localized Language, defaults to English. * * Change this to localize WordPress. A corresponding MO file for the chosen * language must be installed to wp-content/languages. For example, install * to wp-content/languages and set WPLANG to ‘de_DE’ to enable German * language support. */ define(‘WPLANG’, ”); /** * For developers: WordPress debugging mode. * * Change this to true to enable the display of notices during development. * It is strongly recommended that plugin and theme developers use WP_DEBUG * in their development environments. */ define(‘WP_DEBUG’, false); /* That’s all, stop editing! Happy blogging. */ /** Absolute path to the WordPress directory. */ if ( !defined(‘ABSPATH’) ) define(‘ABSPATH’, dirname(__FILE__) . ‘/’); /** Sets up WordPress vars and included files. */ require_once(ABSPATH . ‘wp-settings.php’);

Viewing 8 replies - 1 through 8 (of 8 total)
  • i tried using both firefox and safari from a mac wordpress server is on Rackspace Upuntu 12.04

    Is PHP running? Also, you should change your database login credentials and authentication salts because you’ve just posted them up for everyone to see.

    thanks for that warning! I installed PHP using

    sudo apt-get install php5-mysql

    sudo apt-get install php5-cgi

    sudo apt-get install php5-gd

    So is it running? What happens when you put a test file which only calls phpinfo() ?

    here is the top part from the output from info.php

    PHP Version 5.3.10-1ubuntu3.2

    System Linux servername 3.2.0-25-virtual #40-Ubuntu SMP Wed May 23 22:20:17 UTC 2012 x86_64
    Build Date Jun 13 2012 17:02:21
    Server API Apache 2.0 Handler
    Virtual Directory Support disabled
    Configuration File (php.ini) Path /etc/php5/apache2
    Loaded Configuration File /etc/php5/apache2/php.ini
    Scan this dir for additional .ini files /etc/php5/apache2/conf.d
    Additional .ini files parsed /etc/php5/apache2/conf.d/curl.ini, /etc/php5/apache2/conf.d/gd.ini, /etc/php5/apache2/conf.d/mcrypt.ini, /etc/php5/apache2/conf.d/mysql.ini, /etc/php5/apache2/conf.d/mysqli.ini, /etc/php5/apache2/conf.d/pdo.ini, /etc/php5/apache2/conf.d/pdo_mysql.ini
    PHP API 20090626
    PHP Extension 20090626
    Zend Extension 220090626
    Zend Extension Build API220090626,NTS
    PHP Extension Build API20090626,NTS
    Debug Build no
    Thread Safety disabled
    Zend Memory Manager enabled
    Zend Multibyte Support disabled
    IPv6 Support enabled
    Registered PHP Streams https, ftps, compress.zlib, compress.bzip2, php, file, glob, data, http, ftp, phar, zip
    Registered Stream Socket Transports tcp, udp, unix, udg, ssl, sslv3, tls
    Registered Stream Filters zlib.*, bzip2.*, convert.iconv.*, string.rot13, string.toupper, string.tolower, string.strip_tags, convert.*, consumed, dechunk, mcrypt.*, mdecrypt.*

    Looks like PHP is running. Try uploading a fresh copy of WordPress.


    This specific thread is for installing WordPress on own computer (offline).

    Anyway, if you are wanting to install WordPress on Rackspace Cloud Server, follow this guide. You can use Cloud DNS API (its free) or set the DNS from Rackspace Control panel.

    Also, check the video tutorials in official Rackspace help center.

    Its better to use Debian for Nginx, CentOS or Red Hat for Apache for running WordPress purpose on Rackspace.

    thank you Abhishek and fonglh for you help. And I deleted the whole server at rackspace and did another one

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘when I try to run the /wp-admin/install.php I just get the txt shown below’ is closed to new replies.