Support » Plugins and Hacks » [Resolved] When I translate back to English, the text gets messed up.

[Resolved] When I translate back to English, the text gets messed up.

  • Roc


    Dear Sir,
    I installed the plugin version 2.7 to WordPress 3.7.
    Everything was fine at first.It was doing all things smoothly.But suddenly this bug started.Everytime when I translate my page back to its own language (English) text gets messed up.(The page just shows the first letters of the sentences.)I tried uninstalling and re-installing the plugin but results are same.(Plugin still remembers even its own settings.I cant start from scratch.)
    Should I manually delete some files or tables to reset this?Or is there another solution?
    P.S. You can check the incident from our website.


Viewing 15 replies - 1 through 15 (of 36 total)
  • i am also facing problem when change page language to another, page show only one starting character.

    hi mygameindexdotcom when you resolve this issue. kindly email me,
    because i am facing same error.
    [ redacted, support is offered via the forums and not email ]

    I too am having this problem and would love to know how to fix it. Other than this glitch its a great plugin.

    Same here – Cannot get back to untranslated site once I use this plugin. Even if I shut down the browser it’s still translating Spanish street names into unusable English.

    i am facing same issue
    while interleaving between english and other language. anyhow i am working on when i find solution i will tell you, thanks



    We got no reply. 🙂 Maybe the developer is busy. It’s ok since many users are having the same problem.Anyways you can check the developers’ recent replies to smilar posts Muhammad Kamran.
    I have just tried using Google’s own code.Well the issue continues if you disable the plugin and use the Google’s meta tag and snippet code.So I think it’s not plugin’s fault.
    It maybe something about our themes or webpages either.
    I will try something else. The plugin is uninstalled for now.

    Plugin Author Rob Myrick


    Hi mygameindexdotcom, thank you for the support in your above post. There is one issue that I have found to be a problem in my plugin: I switched over to using the “multilanguagePage” option in version 2.7, which has caused some issues. This has been for a very small percentage of users, mostly in Germany.

    But I am noticing problems with Google too, as I have also tried installing the default translate tool on other users’ websites, and it’s throwing off horrible translations, even single letters that should be entire words.

    For everyone in this thread experiencing the same issue: I would recommend reverting back to version 2.6, and then seeing if that works for you. If the issue still exists, issues will probably be related to theme or Google-specific problems.

    I do have a fix for this, but I would need access to the website, and I can be emailed here: http://www.studio88design.com/get-in-touch/

    I will try and help as much as possible for free until the issues are clear and out in the open.

    Thanks so much!

    Plugin Author Rob Myrick


    Hi muhammadkamran05, your issue is likely related to my configuration change in version 2.7. Would you mind trying version 2.6 and seeing if that fixes your issues? You can download that previous version here: http://downloads.wordpress.org/plugin/google-language-translator.2.6.zip.

    If this does not work, I’m finding that it could be an issue with the theme or with Google directly. A good test for this is to install their Translate tool directly from their website here: http://translate.google.com/

    Let me know if I can help you with this. Thanks!

    I went back to 2.6 and everything is working fine now. Whew! Looking forward to 2.8.

    Plugin Author Rob Myrick


    Lee Hobbs and greenireland, have you been able to re-install version 2.6 and see if that solves your plugin issues?

    Let me know if I can do anything to help. Thanks!

    Here’s version 2.6 if you need it:


    Thanks Rob, I appreciate your response.

    I’ve gone back to 2.6 and everything is working fine. Will keep watching for next update!

    Plugin Author Rob Myrick


    Thanks for reporting back here, greenireland. I’m glad it worked. We will have this issue fixed in version 2.8.




    Hi Rob,
    Thanks for your response!
    I installed version 2.6.It works great in the flag mode. 🙂
    But same issue happens if I try to translate using google toolbar or dropdown language box.

    Plugin Author Rob Myrick


    HI mygameindexdotcom, yes we have almost concluded that this is a Google issue, because we have found that installing the default translator, provided directly from the Google translate site itself, is producing some of the same translation issues on numerous, but not all sites. There is probably some issue of theme conflicts using lots of custom scripts as well.

    The reason the flags work in the plugin is because we use a custom function to access the translations, which somehow bypasses Google’s default function.

    I urge you not to take my word for it, but to go here and try to install the basic version of Google Translate from their website, while fully removing our plugin: http://translate.google.com. You will see what I mean.

    My premium version of the plugin uses custom methods of accessing the translations for both the flags AND the drop-down, when using the custom theme I provide in that plugin. If you are interested in purchasing, the plugin is $12 and you can see a demo of it here http://www.wordpress-studios.com/how-it-works/.

    But you don’t have to purchase it, you can just use the flags functionality for now and you will be fine.

    I think Google made some type of update just last week and this has only been causing issues since then. I’m sorry to deliver bad news!

    Thanks so much for using the plugin.



    You are completely right. Few days after the first error, I removed your plug-in and installed the basic version of Google’s translator. But nothing much changed.
    I will surely consider buying the premium version if I can get the site up and running.It’s still under construction.
    Between your website (http://www.studio88design.com) and its services look really professional.
    Thanks again. 🙂

Viewing 15 replies - 1 through 15 (of 36 total)
  • The topic ‘[Resolved] When I translate back to English, the text gets messed up.’ is closed to new replies.