Support » Plugin: Ultimate Nofollow » When I click nofollow for one link, it changes all the same

  • Please advise on if I am doing something wrong. I just installed this the other day, and it doesn’t work right. I see another review saying the same thing. Is this supposed to work this way? When I click nofollow it does it to all links on the page, not just the one I highlighted.

    UPDATE (in case it helps someone else) : The plugin does work, check out my reply below for more info on what was happening in my case.

    • This topic was modified 2 years, 3 months ago by traveldevoted.
Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author 5fifty

    (@5fifty)

    Hi,

    I have just tested this on a number of WordPress sites and it works correctly.

    There are a few reasons this may be happening to you but none are to do with the plugin –

    You may have selected the option to NOFOLLOW ALL LINKS in the plugin settings (Settings > Nofollow > ‘Nofollow All Blogroll Links’ tick box), just make sure this is deactivated.

    To Nofollow an individual link, you need to edit the individual link within the post you are editing. In the link dialogue box, this shows as a tick box with the text ‘add rel=”nofollow” to link’

    If you have selected to open your link in a new window, WordPress now adds ‘noopener noreferrer’ by default but will not automatically add nofollow.

    Please let me know if you have any more problems.

    I’d really appreciate you changing the 1 star review as the plugin is working exactly as designed. Thanks!

    I investigated a little further. That box was unchecked, so that wasn’t it. What was actually happening was when I clicked nofollow for one link, it worked fine. But the next link I edited would already have the nofollow box checked when I clicked ‘Edit.’ So I mistakenly thought the link was already changed to nofollow. By switching over to the text editor I found that the link was a follow link unless I left that box checked and click save.

    Maybe that will make some sort of sense? Anyway, it does work.

    Plugin Author 5fifty

    (@5fifty)

    Hi,

    That makes sense. We’ll look into fixing this issue on the next release. Thanks for your reply and for the feedback, we appreciate your time in helping us to improve our plugin.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘When I click nofollow for one link, it changes all the same’ is closed to new replies.