Support » Plugin: Ninja Forms - The Easy and Powerful Forms Builder » When forms are submitted button changes to Processing and stays like that

  • Resolved redsoftdev

    (@redsoftdev)


    I have been using Ninja forms on a site and it has been working but now something has happened and the forms can’t be submitted, the submit button changes to Processing and gets stuck there.

    I’ve opened the dev tools and there is already an error before I submit the form. It is SyntaxError: missing ) in parenthetical and file is /plugins/arscode-ninja-popups/js/jquery.material.form.min.js?ver=5.2.1

    When I submit the form the error that is displayed is TypeError: e.errors is undefined and the file is /plugins/ninja-forms/assets/js/min/front-end.js?ver=3.4.5

    I’m using Ninja Forms ver 3.4.13, WP ver 5.2.1 and PHP ver 7.0
    All of the other plugins and themes are up to date.
    I have tried deactivating plugins and themes and then submitting the forms but it hasn’t worked so there doesn’t seem to be any conflicts.

    I look forward to your reply.

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Contributor Justin McElhaney

    (@jmcelhaney)

    It appears that the JS error coming from the Arscode Ninja Popups plugin is causing Ninja Forms not to submit.

    You will need to contact the Arscode support for help with their plugin: https://codecanyon.net/item/ninja-popups-for-wordpress/3476479/support

    Thank you for your assistance. I used the Health Check plugin to activate just a couple of plugins and tested the form and it worked. I turned the checker off and the forms still submitted with the Ninja Popups plugin activated so I’m not sure why I had that error but I’m relieved they are working.

    Hi @jmcelhaney,

    I am having the same issue as TO so I just reply here. If that’s not okay, please let me know 🙂

    When a form is submitted, the button turns to Processing and also gets stuck. Deactivating and reactivating some plugins told me that a specific plugin causes this: Shortcode Variables.

    I checked the JS files of the this plugin, but can’t find any missing stuff using an editor that highlights errors.

    Now, do I need to contact them and if yes what should I tell them, since they are not aware of the cause: I don’t know how to create such a specific error report as TO, so I don’t have a clue what’s going on 😅

    Some help would be lovely 🙂

    Thanks!

    EDIT:

    – Switching off AJAX in the forms ‘resolves’ the problem. But of course that’s just a workaround.

    – I turned on WP_DEBUG and when I looked on the form page in the admin area I saw a new form was magically created! The title/name(!) of this form is:

    Notice: Undefined index: form_title in /var/www/vhosts/xxxxxxxx/httpdocs/wp-content/plugins/ninja-forms/deprecated/includes/admin/pages/ninja-forms/tabs/form-list/form-list.php on line 185

    That’s kind of strange haha. Of course it’s an empty form.

    – Also on the top of the forms page in the admin it says:

    Notice: Undefined index: date_updated in /var/www/vhosts/lijfhartenziel.nl/httpdocs/wp-content/plugins/ninja-forms/deprecated/includes/admin/pages/ninja-forms/tabs/form-list/form-list.php on line 169

    Maybe this is helpful.

    • This reply was modified 5 months, 2 weeks ago by ldwd.
Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.