Support » Plugin: Appointments » When Client Deletes Event –> Google Calendar Doesn’t Delete Event

  • mcatselfprep

    (@mcatselfprep)


    When a client deletes an appointment, Google Calendar does not automatically delete the event. I have to manually go in and delete these events which can be very cumbersome. Is there something I can do to fix this issue? Thank you!

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Contributor Dimitris – WPMU DEV Support

    (@wpmudev-support6)

    Hello @mcatselfprep,

    hope you’re doing good today! 🙂

    First of all, you should select the A+ <-> GCal option, so any changes happened in each end, will inform the other (complete synchronization).

    I already tested that in my end, and after removing the appointment from both backend as an admin and from frontend using the [app_my_appointments allow_cancel="1"], resulted in the GCal event to be removed.

    If you already use the above option, then this should be happening due to some conflict with another plugin/theme, so please the followings:
    – backup your website (files & database)
    – deactivate all plugins apart from Appointments
    – activate a default theme like TwentySeventeen
    – try to add, then remove/cancel an appointment and check GCal
    If the issue is resolved, start activating the remaining plugins and theme, one by one this time, making a little add/cancel test each time, until you replicate the issue again, thus finding the conflicted combination.
    Let us know, how that goes!

    Warm regards,
    Dimitris

    Plugin Support Jonathan – WPMU DEV Support

    (@wpmudev-support9)

    Hello @mcatselfprep

    Hope you’re doing well!

    We’ve not heard from you in a while. I’ve marked this ticket as resolved for now, but if you need anything else at all, we’re here for you, please just reopen the ticket or create a new one.

    Have a great day!

    Cheers,
    Nastia

    Thread Starter mcatselfprep

    (@mcatselfprep)

    Sorry for the delayed response. I have all the options checked that I need to according to what you told me but it still isn’t working. I have a different calendar for each provider — perhaps this is where the bug is?

    Plugin Support Jonathan – WPMU DEV Support

    (@wpmudev-support9)

    Hello @mcatselfprep

    Hope you’re doing well!

    I am afraid you can synchronize only one calendar with the Appointments+, the one that is selected within the plugin settings:

    Share this calendar with the server providers so the appointments would be removed automatically from the Appointments list when an appointment is deleted from Google Calendar.

    Let us know if you have any further questions!

    Kind regards,
    Nastia

    Thread Starter mcatselfprep

    (@mcatselfprep)

    Sorry I am not sure I understand. I thought the “Allow Service Providers for Google Calendar API Integration” option allowed you to let service providers sync their own google calendar?

    Plugin Contributor Dimitris – WPMU DEV Support

    (@wpmudev-support6)

    Hello @mcatselfprep

    No, that’s true, you can also have additional Google Calendars connected via the profiles of your service providers.

    Could you please let me know about the exact settings you have in
    Appointments -> Settings -> Google Calendar
    so I can try to replicate once more?

    Basically I want to know, if you also enabled a Google Calendar integration there, like a global one, and what’s your selection for the “Appointments will be sent to Google Calendar for” setting.

    Warm regards,
    Dimitris

    Thread Starter mcatselfprep

    (@mcatselfprep)

    Thanks for looking into this for me. Everything about the two way sync works EXCEPT when a user deletes an appointment from their end, the event is not deleted from my google calendar. I have to manually go in and delete the event in google calendar whenever a user cancels an appointment.

    Here are my general settings: https://imgur.com/xHRUO9q

    Here are the settings for me as the user: https://imgur.com/E17ooW2

    Plugin Support Adam – WPMU DEV Support

    (@wpmudev-support8)

    Hey @mcatselfprep,

    Hope you’re well.

    Thank you for sharing these screenshot. I can replicate the same problem with your exact settings. I am informing developers about that. By the way, you can set “API Mode” to two way sync from global settings Appointments > Settings > Google Calendar page for the temporary solution.

    You don’t need to select any global calendar you just need to select sync option.

    I hope it helps for now!

    Cheers,
    Oguz

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘When Client Deletes Event –> Google Calendar Doesn’t Delete Event’ is closed to new replies.