Support » Plugin: Shariff Wrapper » Whatsapp wird auf Desktop Browser angezeigt

  • Resolved detoris

    (@detoris)


    Hallo,

    ich habe gerade das neueste Update installiert. Bei der Kontrolle der Share Buttons in den Beiträgen ist mir aufgefallen das nun ein Whatsapp Button auf meinem Desktop Browser Firefox zu sehen ist. Wenn man diesen drückt, bekommt man natürlich eine Fehlermeldung mit einer weißen Browserseite mit dem Text: Adresse nicht erkannt.

    Kann ich/man da was ändern oder soll das in Zukunft so sein?

    Vielen Dank

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Jan-Peter

    (@starguide)

    Hallo detoris,

    WhatsApp unterstützt seit November 2018 nun auch endlich WhatsApp Web beim Sharen. Das funktioniert bei Chrome, Edge, IE 11 und Co. auch prima. Bei Firefox gibt es, je nach eigener Einstellung des Browser, da leider auf Seiten von WhatsApp noch Probleme (wird fälschlicherweise als Mobilgerät erkannt). Ich gehe aber mal davon aus, dass sie das bald abgestellt haben werden.

    Eventuell baue ich zwischenzeitlich noch eine Option ein, damit man sich je nachdem entscheiden kann, welche Browser einem wichtiger sind. Ansonsten braucht man im Moment auch nur einen Eintrag ändern (sofern man sich das per FTP zutraut) und zwar in der /wp-content/plugins/shariff/services/shariff-whatsapp.php in Zeile 30 von
    $mobile_only = 0;
    auf
    $mobile_only = 1;
    ändern.

    Viele Grüße
    JP

    Vielen Dank für die Info. Ich habe es direkt geändert, da es zur Zeit vielleicht mehr verwirrt als hilft. Nun ist wieder alles in Ordnung.

    Plugin Author Jan-Peter

    (@starguide)

    Dann ist ja gut. Ja, das ist eine Ermessensentscheidung. Ich war die im Schnitt zwei E-Mails pro Woche leid, die fragten, warum WhatsApp nicht auf dem Desktop angezeigt wird, das würde doch gehen. Mal schauen, ob es andersherum weniger Nachfragen sind. 😉

    LG
    JP

    Das kann ich gut verstehen. Vielleicht kann man es ja defaultmäßig sichtbar und optional unsichtbar machen. B-) Dann hätte man vielleicht Ruhe. B-)

    Moin,

    bin wegen des gleichen Anliegens hier. Wäre es sonst möglich die Option per Filter setzen zu können?

    $mobile_only = apply_filters( 'shariff_services_whatsapp_mobile_only', 0 );

    VG

    Plugin Author Jan-Peter

    (@starguide)

    Hallo Daniel,

    man kann auch einfach unter Design -> Customizer -> Zusätzliches CSS folgendes eintragen:

    @media only screen and (min-device-width: 1025px) {
        .shariff .whatsapp { display: none; }
    }

    Was anderes macht Shariff auch nicht und dann ist es update-sicher.

    LG
    JP

    o.k. danke auch von mir für die Alternative d.h. wenn Du in die nächste Version keine Option einbauen kannst, werde ich dieses Weg wählen, auch wenn mein zusätzliches CSS schon recht groß ist.

    Plugin Author Jan-Peter

    (@starguide)

    Kann dich beruhigen, die Option kommt, ist schon fertig. Warte nur mit dem Release noch auf WP 5.1, um zu sehen, ob sonst noch was zu ändern ist.

    Viele Grüße
    JP

    Hat Dir schon mal jemand gesagt wie genial Du bist?
    Vielen Dank für Deine Mühe!

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.