Support » Plugin: The SEO Framework » WhatsApp Image Missing

  • Resolved backpackingseries

    (@backpackingseries)


    Hi,

    Thank you for the fab plugin.

    I get the FB image. However, a WhatsApp image is not shown – neither site logo nor the image/s set in the plugin. Any suggestions please?

    Kind regards,

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Sybre Waaijer

    (@cybr)

    Hello!

    My apologies for my absence. I tested a few pages, and the WhatsApp image is showing up just fine for me! Are you still encountering issues with this?

    Please note that if you send a link ‘too quickly’ in WhatsApp, it won’t be able to process and relay the metadata for you, and as such, you won’t see the image or other meta attached to the message. I believe the metadata relayed is attached to the message and stored on your and the receiver(s) device(s); so, if it fails to retrieve it in time, no one will see it.

    Thread Starter backpackingseries

    (@backpackingseries)

    @cybr Thank you so much for trying it out and the helpful response.

    For some reason, the hompage thumbnail is not shown on my WhatsApp. The rest of the site pages work just fine.

    When you tried, did the hompage (with or without the trailing slash) work okay as well?

    Kind regards,

    Plugin Author Sybre Waaijer

    (@cybr)

    Hello!

    I see the issue, but I’m not sure what the cause is. WhatsApp doesn’t provide us a debugger.

    Could you try selecting your preferred image via the “Select Image” button for the homepage (preferably via the SEO Settings page) — instead of inputting the image URL manually? Doing it this way will allow TSF to process the image and select the best version for sharing, among outputting additional image details, such as the width and height.

    Also, at the Social Meta Settings on the SEO Settings page, see if unchecking “Output multiple Open Graph image tags?” helps. We’re considering defaulting it to unchecked for new sites in the future because it’s causing erratic behavior on some platforms.

    If these changes don’t resolve the issue immediately, you may want to check again in a day, or at least try to force-quit and relaunch WhatsApp on your device. Caching is a big culprit with testing.

    Thread Starter backpackingseries

    (@backpackingseries)

    Thank you so much @cybr I’ll try these steps out.

    Kind regards,

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.