Support » Plugin: Rank Math SEO – Best SEO Plugin For WordPress To Increase Your SEO Traffic » Whatsapp don’t Show Some images on OpenGraph meta tag

  • Resolved valderes

    (@valderes)


    Hello.
    I’m facing a situation with open graph meta tags.
    The opengraph meta tags are correctly configured on every page of my site where they should work.
    When sharing on social networks, they work correctly. As much as I tested it with the Facebook and LinkedIn tool, none of them reported an error.
    The problem occurs when sharing some post types (one of them, woocommerce product single page).
    I read in other threads that this problem can be related to the size of the images and their weight.
    Objection 1: almost all my images weigh less than 100k
    Objection 2: Whatspap displayed some 1280px wide images
    Objection 3: Some of my images accidentally weighed over 300k, yet whatsapp displayed them.
    Can someone help me?

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Rank Math

    (@rankmath)

    Hello @valderes,

    Thank you for contacting the support and sorry for any inconvenience that might have been caused due to that.

    There are a few reasons for Facebook (or any other social network like WhatsApp) not picking your images and other social tags. We will list them below so you can check which one applies in your case:

    1. First and foremost, you must check the page source of the URL in question. Search for the og:image tag like in this Video:
    https://i.rankmath.com/aJCccE

    If the og:image tag is not found, that means Rank Math is either disabled or not able to print your social tags. Once done checking if Rank Math is enabled, you must check why it isn’t able to print social content by following this troubleshooting guide:
    https://rankmath.com/kb/check-plugin-conflicts/

    Make sure to follow all the instructions carefully.

    2. Assuming the og:image tag was found in step 1, we can proceed to find the issue.

    Scenario 1: You are using minification on your website and your cache plugin is inputting too much inline CSS into your page source that your OpenGraph tags are pushed way too down your page’s source:
    https://i.rankmath.com/y4WIgQ

    If this is the cache, you must move your inline CSS to a file because Facebook and other social networks will only look for OpenGraph tags in the first 60kbs of your page’s source. If they don’t find it, they will assume you haven’t added them. They don’t want to waste their resources crawling huge pages looking for OpenGraph tags.

    Scenario 2: The gain browser cache option in most cache plugins like W3 Total Cache is known to not play well with Facebook’s OpenGraph detection. If you have it enabled, disable it. The option for W3 Total Cache is at WP > Performance > Browser Cache > HTTP (gzip) compression
    https://i.rankmath.com/BbaiC6

    Then, clear your website and server cache (including Cloudflare – if enabled)

    Once you are done, you might want to test again here:
    https://developers.facebook.com/tools/debug/

    Click the Scrape Again button:
    https://i.rankmath.com/A5z7WK

    You should now see the OpenGraph tags update including the image.

    Hope that helps and please do not hesitate to let us know if you need our assistance with anything else.

    Thread Starter valderes

    (@valderes)

    Hi @rankmath team. Thankyou for your reply.

    As I said before, the meta tags are correctly inserted in the html code, they appear right at the top. When submitting the url to the facebook test tool (https://developers.facebook.com/tools/debug/), it does not report any error, even after clicking the “Scrape Again” button.
    When sharing on social media everything appears correctly, as expected.
    The problem happens only in whatsapp.

    Thread Starter valderes

    (@valderes)

    complementing the previous post, this behavior only occurs on woocommerce product pages

    Plugin Author Rank Math

    (@rankmath)

    Hello @valderes

    Tried sharing the link in WhatsApp and everything seems to be working fine. Here’s a screenshot:
    https://i.rankmath.com/VepF6N

    Since the debugging tool is not showing any error(s), the issue might be arising from your server’s speed/slow connection/etc.

    There is hardly anything Rank Math can do to influence the social media image’s preview while sharing on WhatsApp.

    You might want to drop a message to WhatsApp’s support:
    https://www.whatsapp.com/contact/?lang=en&subject=messenger

    Hope that helps. Thank you.

    Thread Starter valderes

    (@valderes)

    Thank you @rankmath team.

    In the time interval between the opening of this topic and your reply, we have not made significant changes at the code level. But we performed a hard reset of the cache, in addition to server performance improvements. Which may have contributed to the solution of the problem, confirming his argument that the problem was in the performance.

    Plugin Author Rank Math

    (@rankmath)

    Hello @valderes

    Glad that’s sorted!

    Please feel free to reach out again in case you need any other assistance, we are here to help.

    If it isn’t too much to ask for – would you mind leaving us a review here?
    https://wordpress.org/support/plugin/seo-by-rank-math/reviews/#new-post

    It only takes a couple of minutes but helps us tremendously.

    It would mean so much to us and would go a really long way.

    Thank you.​​

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Whatsapp don’t Show Some images on OpenGraph meta tag’ is closed to new replies.