WordPress.org

Support

Support » How-To and Troubleshooting » WHAT THE HELL!!! HELP!!!

WHAT THE HELL!!! HELP!!!

Viewing 14 replies - 1 through 14 (of 14 total)
  • And here I was, wondering that I hadn’t seen any “worst title of the day” candidates for the last few days. 😉

    In your errors, see this? errno: 145 That’s a techy way of saying Not a WordPress issue.

    That’s a MySQL error. If you have phpMyAdmin, you might try repairing your tables. Or you might contact your host directly and let them know your database is unhappy.

    For some reason, when I load phpmyadmin and check out the database, I get this for js_posts table

    SQL query: Edit
    SHOW KEYS FROM
    js_posts ;
    MySQL said: Documentation
    #1016 - Can't open file: 'js_posts.MYI' (errno: 145)

    I realize its not a wordpress issue, but I was pretty sure someone has experienced this issue and might have a cause and possibly a solution. I manage my own server — for the most part, never had an issue like this.

    Did you try the repair table option?

    repairing the database is most likely going to solve the problem for ya.

    Well I ran a myisamchk -r js_posts.MYI

    and it appeared to have done something.. it changed the error to
    WordPress database error: [Can't open file: 'js_posts.MYI' (errno: 13)]

    What is the correct way to “repair” the database?

    maybe a quick search or post here? http://forums.mysql.com/

    I did a search and I’m seeing some results, trying everything still doesn’t appear to be helping, Handy do you know.. if so, I mean if you know an easy fix or exact command could you tell me?

    I’ve ran myisamchk --safe-recover myisamchk -r the check sequence, repairs etc.. don’t seem to be getting anywhere..

    go to phpmyadmin.

    select the database.

    select all the tables.

    choose the option which says repair. do an optimize after that.

    This is offered with no guarantees or warranty 😛

    Last time I had this happen, I just fired up phpMyAdmin, selected the DB then selected the table. Clicked on the “Operations” tab and somewhere towards the bottom was “Repair Table.”

    That fixed me.

    I did as you mentioned and I get this Can't open file: 'js_posts.MYI' (errno: 13)

    It says OK next to every other table.. this is nuts

    I feel retarded, I backed up the table js_posts.MYI as root and copied it over, forgot to chown, chgrp back to mysql..

    Fixed, thanks guys! Appreciate it.

    Lol! Glad you got it going — and thanks for letting us know what the “root cause” was (ok, bad pun).

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘WHAT THE HELL!!! HELP!!!’ is closed to new replies.
Skip to toolbar