Support » Plugin: FLC forma.lms connector » What settings to put in formalms? Reponse is showing null

  • Resolved Fahad

    (@fahadtariq)


    Hi,

    I tried to set this plugin up but I am having issues.

    I can see the SSO and API Key/Secret settings that I must input in formalms and wordpress. So I did that.

    But, checking the logs, it always shows response: null. So connection isn’t working correctly. What do I need to put in formalms “Single code for platform” and what should the “Authentication method” be?

    I am using the latest forma 2.0. Thanks!

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author JT dev

    (@jtdevel)

    “Single code for platform” :-> this configuration is not used by plugin

    “Authentication method” :-> Authorization security key

    Check the address of forma.lms installation you put in configuration. must be complete with the full path of forma.lms (if forma.lms is published in a subfolder)

    Plugin Author JT dev

    (@jtdevel)

    we pulished a new version ( 1.2 ) with a better handling of curl’s errors.

    Fahad

    (@fahadtariq)

    So the settings seem fine then. Curl etc is working fine since I am getting a successful 200 error from formalms. It is returning a full page though in the body instead of the result from the API. The path is correct (it is not installed in a subfolder).

    On Formalms side, I am using php 7 and safe mode is off. Not sure if either of those things might be the issue. I will keep debugging and see what the issue is.

    Fahad

    (@fahadtariq)

    I tried the new version 1.2 and still same issue.

    Plugin Author JT dev

    (@jtdevel)

    uhmm … it’s very strange the response as full body page

    please, from a command shell on the server where you installed WP try the command
    curl http://your.formalms.domain.com/dev/api/user/listUsers
    or
    wget http://your.formalms.domain.com/dev/api/user/listUsers
    using your formalms url
    if the url is correct and you can contact formalms api, you will get an xml response with “error” content (no authentication specified)
    if you retrieve a full html pages , check the formalms installation …

    Fahad

    (@fahadtariq)

    Yes, I also found the full page HTML return suspicious. We are using nginx as the server so there might be some configuration needed there. I will take a look and report back if I find a fix. The rest of forma lms seems to be working smoothly however. Could you verify that the server config seems okay? (we are using https) Thanks!

    Server configuration
    Server port: 443
    Server admin email:
    Server software: nginx/1.15.0

    MySQL information
    sql vers: 5.5.5-10.3.7-MariaDB-1:10.3.7+maria~xenial-log
    sql mode: “”
    sql encoding: utf8
    sql collation: utf8_general_ci
    sql timezone: SYSTEM

    Info about PHP
    PHP version: 7.0.32-0ubuntu0.16.04.1
    Site Timezone: UTC
    “safe_mode” configuration: Off
    Configuration of “register_global”: Off
    Configuration of “magic_quotes_gpc”: Off
    Configuration of “upload_max_filesize”: 128M
    Configuration of “post_max_size”: 128M
    Configuration of “max_execution_time”: 230s
    LDAP: Off Consider this parameter only if you need to authenticate through LDAP
    Configuration of “allow_url_include”: Off
    PHP extension php_openssl: On
    Configuration of “allow_url_fopen”: On

    Plugin Author JT dev

    (@jtdevel)

    The server configuration seems correct.

    The errors (full body page) is related with nginx server.
    the plugin call formalms api wth the “rest notation” (pretty urls) that is translated into real request by .htaccess rules and htaccess file is not supported by nginx.

    Please configure nginx with a set rules get from .htaccess under api folder and properly transled.

    This issue will be adressed in a future release.

    Fahad

    (@fahadtariq)

    Got it! I think we will set up an apache server to handle this for now. If we do set this up on nginx, we will post back the nginx specific rules here for others’ help.

    Thanks! 🙂

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘What settings to put in formalms? Reponse is showing null’ is closed to new replies.