Support » Localhost Installs » What “Settings → Permalinks Screen”?

  • I am attempting to use the current WordPress documentation of the REST API. This exemplifies the issues I’m having coming up to speed on WordPress.

    Specifically — Choosing your permalink structure.

    The text says (emphasis mine):

    In the <b>Settings → Permalinks</b> Screen, you can choose one of the more common permalink structures or enter your own in the “Custom structure” field using the structure tags.

    Please note: You do not put your site url in the permalinks fields. You only use one of the structure tags, or a combination of tags.

    To activate PATHINFO permalinks, start your permalink structure with index.php/.

    I assume, perhaps incorrectly, that this refers to the “Settings” section of the wp-admin dashboard. At least in v5.8.1, I see no “Permalinks” entry.

    What, if anything, do I need to do in order to configure and use “Pretty Permalinks”?

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Moderator t-p

    (@t-p)

    Admin panel>>>Settings>>>Permalinks

    Try reading Using_Permalinks

    Thread Starter somervilletom

    (@somervilletom)

    We seem to be talking past each other.

    “Using Permalinks” is the page I started from.

    I invite you to clarify where on that page ANY information is provided about how to make permalinks work.

    I’ve already added the “.htaccess” file with the changes suggested.

    I see nowhere in the “wp-admin” dashboard that I have ability to specify those. Those settings certainly are NOT in “Settings -> Permalinks” — because there is no such page on the “wp-admin” screen I see.

    Thread Starter somervilletom

    (@somervilletom)

    Ok, Now I see it.

    I didn’t scroll down far enough to see the “Permalinks” item in the left-hand pane of the WP-admin screen. It was hidden at the bottom of the browser window.

    When I see “Settings -> Permalink”, I expect to see “Permalink” in the pane that appears when I click the “Settings” button. It shows “General”, and of course that’s the wrong pane.

    I understand the UI, it’s the same approach the Microsoft takes in too many front-ends.

    Ok, at least we’re on the same page now (pun intended) 🙂

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.