Support » Plugin: TheCartPress eCommerce Shopping Cart » What PHP version?

  • Joy

    (@joyously)


    I got my store loaded on my local test server, but when I set it all up on the actual server, I get parse errors in TheCartPress plugins.
    The real server is running older versions of MySQL and PHP.
    I couldn’t find anywhere on your plugin page or your plugin site what version of PHP you require. You just mention the WordPress version.

    Can you put the version requirements in the readme file?

Viewing 4 replies - 1 through 4 (of 4 total)
  • Generally, unless a plugin author specifies differently, a plugin will work with whatever version of PHP/mySQL that WordPress supports.

    Joy

    (@joyously)

    That’s why I wondered what version this plugin requires because WordPress has a much lower requirement. I had it working on my test site, but it does not work on my real site.

    Plugin Author Inigo Gonzalez

    (@inigoini)

    Hi Joy,

    Could you send me the troubles you have in your site?
    I think, that TheCartPress uses the same PHP version that WordPress uses.

    Best regards

    Joy

    (@joyously)

    Sensei,
    I would paste the parse error here except that I had my host move the account to a newer server, and it works now.

    The old server had PHP 4.3.11. The new one has PHP 5.2.6.
    I really don’t know that it was the PHP version (it seems like it since it was getting a parse error), but it was also very restrictive in the permissions and WordPress could not write to any directories. Once the site was moved, I still had both problems. Then they changed how the web processes were handled and it fixed both problems.

    The problem was definitely in the plugin because it would run WordPress just fine, although restricted, but the plugin would not activate due to a parse error. So you can’t say you have the same requirement for PHP as WordPress.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘What PHP version?’ is closed to new replies.