Support » Plugin: Header and Footer Scripts » What PHP version is required?

  • Hello,

    The changelog for recent version 2.1.1 says: “Now require PHP v7.0 at least.” However, the plugin meta information still have “Requires PHP: 5.6” listed.

    I skimmed through the code quickly and there seems to be no feature that requires PHP 7. I had also no problems upgrading the plugin on my PHP 5.6 installation. Could you clarify?

    Cheers
    Česlav

    • This topic was modified 6 months, 1 week ago by Česlav Przywara. Reason: Fix typo
Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Anand Kumar

    (@anand_kumar)

    There is no PHP v7 code but we are going to push users to switch to a supported PHP version. It will ultimately help them to make their site secure and bring performance improvement.

    But, I have to temporarily roll back it because some users are still on v5.6. However, In the next update it will be v7.x for sure.

    HTH.

    Thanks for clarification! I’m generally in favor of pushing users towards more recent PHP versions.

    Please, just don’t forget to update “Requires PHP” header when the version bump happens. I guess a lot of people (like I do) still has to maintain some PHP 5.x installations.

    Plugin Author Anand Kumar

    (@anand_kumar)

    Hi,

    It was a bug fix update with change in “Requires PHP”. But after some feedback I decided to roll back the “Requires PHP” thing.

    Thanks for the feedback.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘What PHP version is required?’ is closed to new replies.