Support » Plugin: WPSiteSync for Content » What needs to be enabled for this plugin to work

  • Resolved iLoveCake

    (@ilovecake)


    For security reasons, we have XML-RPC and JSON REST V1/V2 disabled on our site. In addition, we have rewrites in place to mask all default WP paths, such that you wont be able to access /wp-admin for example.

    Will these measures prevent this sync plugin from working?

    Thanks

Viewing 1 replies (of 1 total)
  • Plugin Author ServerPress

    (@serverpress)

    Hi ilovecake,

    Thank you for your interest in WPSiteSync. This is a great question.

    The WPSiteSync plugin does not use XML-RPC or the REST API to perform it’s API operations. It also does not rely on the /wp-admin URL for any of it’s operations. The security measures you describe don’t sound like anything that would affect the performance of our APIs. We also take into account the current URL structure needed for image references, so if you are not using the same WP path structure on the Source and Target, the paths will be adjusted so that the content and images work correctly once everything arrives on the Target site.

    All that said, there may still be other plugins and non-standard configurations in your install. While we’ve taken all the steps we can think of to ensure everything works in all environments, the only way to know is to test. If you do find any problems we would appreciate the opportunity to work with you and resolve any issues you may come across.

    And we love cake too. 🙂

    All the best,
    The ServerPress Team

Viewing 1 replies (of 1 total)
  • The topic ‘What needs to be enabled for this plugin to work’ is closed to new replies.