Support » Fixing WordPress » What is “/wp-content/endurance-page-cache/”? Creating thousands of directories?

  • Resolved DabidK


    I happened to log into my Bluehost account today and noticed that I got a File Count error telling me “Your account contains more than 9740 directories and may pose a potential performance risk to the server.<br>Please reduce the number of directories for your account to prevent possible account deactivation.”

    I was really surprised to see this, as I was nowhere NEAR that number of directories a month or so ago the last time I checked. I went into my File Manager and discovered that I had THOUSANDS of new directories created that are all either totally empty or have 1 file in them and that are all along the lines of:

    1 : /home1/toyrevie/public_html/halotoynews/wp-content/endurance-page-cache/2012/06/25/halo-micro-ops-series-1-falcon-high-ground-bunker-official-photos
    1 : /home1/toyrevie/public_html/halotoynews/wp-content/endurance-page-cache/2012/06/24/halo-micro-ops-series-1-smalled-carded-sets-official-photos-2012
    1 : /home1/toyrevie/public_html/halotoynews/wp-content/endurance-page-cache/2012/06/24/halo-micro-ops-series-1-high-ground-gate-mcfarlane-official-photos/embed
    1 : /home1/toyrevie/public_html/halotoynews/wp-content/endurance-page-cache/2012/06/24/halo-micro-ops-series-1-high-ground-gate-mcfarlane-official-photos
    1 : /home1/toyrevie/public_html/halotoynews/wp-content/endurance-page-cache/2012/06/22/halo-mega-bloks-warthog-resistance-set-fully-revealed
    1 : /home1/toyrevie/public_html/halotoynews/wp-content/endurance-page-cache/2012/06/19/tons-halo-mega-bloks-news-facebook-qa
    0 : /home1/toyrevie/public_html/halotoynews/wp-content/endurance-page-cache/category
    0 : /home1/toyrevie/public_html/halotoynews/wp-content/endurance-page-cache/2016/08/27
    0 : /home1/toyrevie/public_html/halotoynews/wp-content/endurance-page-cache/2016/08
    0 : /home1/toyrevie/public_html/halotoynews/wp-content/endurance-page-cache/2016/07/17
    0 : /home1/toyrevie/public_html/halotoynews/wp-content/endurance-page-cache/2016/07/06
    0 : /home1/toyrevie/public_html/halotoynews/wp-content/endurance-page-cache/2016/07/05
    0 : /home1/toyrevie/public_html/halotoynews/wp-content/endurance-page-cache/2016/07/02
    0 : /home1/toyrevie/public_html/halotoynews/wp-content/endurance-page-cache/2016/07
    0 : /home1/toyrevie/public_html/halotoynews/wp-content/endurance-page-cache/2016/06/24
    0 : /home1/toyrevie/public_html/halotoynews/wp-content/endurance-page-cache/2016/06/23
    0 : /home1/toyrevie/public_html/halotoynews/wp-content/endurance-page-cache/2016/06/16
    0 : /home1/toyrevie/public_html/halotoynews/wp-content/endurance-page-cache/2016/06/12
    0 : /home1/toyrevie/public_html/halotoynews/wp-content/endurance-page-cache/2016/06/11
    0 : /home1/toyrevie/public_html/halotoynews/wp-content/endurance-page-cache/2016/06/10
    0 : /home1/toyrevie/public_html/halotoynews/wp-content/endurance-page-cache/2016/06/09
    0 : /home1/toyrevie/public_html/halotoynews/wp-content/endurance-page-cache/2016/06/08
    0 : /home1/toyrevie/public_html/halotoynews/wp-content/endurance-page-cache/2016/04/29
    0 : /home1/toyrevie/public_html/halotoynews/wp-content/endurance-page-cache/2016/04/03
    0 : /home1/toyrevie/public_html/halotoynews/wp-content/endurance-page-cache/2016/03/22
    0 : /home1/toyrevie/public_html/halotoynews/wp-content/endurance-page-cache/2016/03/17
    0 : /home1/toyrevie/public_html/halotoynews/wp-content/endurance-page-cache/2016/03/11
    0 : /home1/toyrevie/public_html/halotoynews/wp-content/endurance-page-cache/2016/02/15
    0 : /home1/toyrevie/public_html/halotoynews/wp-content/endurance-page-cache/2016/02/12
    0 : /home1/toyrevie/public_html/halotoynews/wp-content/endurance-page-cache/2016/01/20
    0 : /home1/toyrevie/public_html/halotoynews/wp-content/endurance-page-cache/2016/01/16
    0 : /home1/toyrevie/public_html/halotoynews/wp-content/endurance-page-cache/2016/01/14
    0 : /home1/toyrevie/public_html/halotoynews/wp-content/endurance-page-cache/2016"

    These example directories are all from, but this problem is recurring across several of my other domains as well and I have no idea why. I don’t even have a caching plugin! I’ve never seen this Endurance-Page-Cache thing before and I have no idea what to do with it or how to delete these weird directories.

    Does anyone know what “Endurance-Page-Cache” is and how to disable it?

    • This topic was modified 4 years, 11 months ago by DabidK.
    • This topic was modified 4 years, 11 months ago by DabidK.
    • This topic was modified 4 years, 11 months ago by Steve Stern (sterndata). Reason: put code in code tags
Viewing 15 replies - 1 through 15 (of 26 total)
  • Thread Starter DabidK


    Upon studying the File Manager more, I can see that whatever this Endurance-Page-Cache thing is, it has created a whole new directory for every single post AND photo that I’ve ever uploaded to one of my domains. So I can see WHY I have over 12,000 directories now, but I have no idea why it’s happening or how to stop it/fix it.

    Moderator Steve Stern (sterndata)


    Forum Moderator & Support Team Volunteer

    based on this page — — I’d say it’s a plugin from BlueHost, probably installed as an MU plugin. If you have questions about it, please contact their tech support.

    Thread Starter DabidK


    Thanks Steve! I didn’t realize it was a Bluehost-installed plugin. I’ll reach out to them about it.


    Those directories are not a security risk, since it is just the content of a static caching plugin.

    So when a visitor views your site they hit the HTML static cache version and it does not have touch WordPress or PHP and render out that page.

    • This reply was modified 4 years, 11 months ago by Luke Cavanagh. Reason: clarify wording

    Maybe this will help others the Endurance-Page-Caching problem…

    Working on a site Hosted from who uses their vDeck hosting platform. I kept getting old pages served with outdated code and images.

    To solve:
    I both called FatCow and asked them to turn off this caching (the control panel also has a caching settings page which does not turn this off) and they said their change would take a couple hours to work??.

    But the real solution which I believe helped was renaming the endurance-page-caching folder – I added “_old” to the folder name and hours and days of frustration were relieved when I saw the correct pages and correct images load FINALLY!

    After testing a few changes, the problem so far is that the server has created a new folder for endurance-page-cache and changes are not showing up – hopefully after a few hours this will stop.

    This endurance-web-page thing is not a plugin users can remove from WP control panel, that I can see, and it is something the hosting companies are adding to reduce server loads.

    It should be removed from all hosting companies since it is causing such frustration for developers. Please get rid of junk that causes problems!

    @edwardjonesdesign THANK YOU a million times! I have a client on Bluehost whose website wasn’t showing updates when logged out, but it DID show them when I was logged in. I waited two days and checked back, and the updates were STILL not displaying. I finally dug through the files and found the endurance-page-cache folder. Solved the problem right away. It’s incredibly annoying that they would subject users to this, particularly since I couldn’t find any sort of mechanism in the hosting control panel to turn it off.


    Version 0.30 of Endurance Page Cache has additional purging options so you can clear your site cache as you are working on your site.

    @lmkweb – glad it helped. I have also found this can be disabled for good by deleting the 2 files inside the MU plugin folder.

    @lukecavanagh – thanks. I still do not like the fact that this isn’t clear to developers. We spend hours trying to figure out what is going on even after hosting support says all caching has been turned off and the control panel shows WordPress caching is turned off?

    If I want caching to increase the load speeds of my site I will add the plugin myself. Most sites do not have a problem with load speeds as they are smaller business, non-profit, mom & pop, etc. IMO. They just don’t have the user loads and do not create the server load as large sites do.

    Thought I’d add my two cents. I first sas this plugin mentioned via my Sucuri updates. I couldn’t figure out where it had come from. I hadn’t installed it. Meanwhile, my blog wasn’t updating after I published a new post. I post every day. My readers were coming to my blog and thinking I hadn’t posted in several days because they weren’t getting updated posts. I was on the phone with BlueHost about this at least twice and I wrote them an angry letter, as well. I lost ad income during that time. My main complaint was that it stopped my site from working correctly and, even more importantly, they had installed it without my permission. The techs had clearly been getting a lot of complaints about it. They renamed the folders, the techs saying that renaming them was a good idea so no one at BlueHost would decide to ‘install’ it again in the future. They also had to make an adjustment to some code in .htaccess.

    I deliberately chose to NOT have a caching plugin on my site and then they went ahead and added it. It’s also named after the company that now owns Bluehost.

    I find it baffling that BlueHost chose to go down the route of installing an unsolicited plugin on their customers’ WP installations without even notifying them about it.

    The fact that we need to also install the Mojo Marketplace plugin in order to be able to configure this cache -which is causing my client’s WordPress website to serve outdated pages- makes it even more infuriating.

    I know this forum is not the right place to complain about the unwanted installation, but as current BH customers we need to be vocal about such a bad idea.

    Just ran into this issue with a client using Bluehost and just wanted to add that deleting/renaming the endurance-page-cache folder did nothing for me. It just regenerated. The only way to disable was to go to Plugins > Must Use and disable there. Hope this helps prevents someone else from wasting so much time figuring it out or on a Bluehost phone/chat hold.

    Thank you, Alfonso! The endurance-page-cache plugin was messing up my Form Maker’s forms because they were all getting cached. Now they are working fine.

    The exact same problem with HostMonster (which is another brand owned by BlueHost which runs on the same platform). We use a geo-location plugin to display correct information based on the visitor’s country. This Endurance Page Caching broke that completely. Installed without our consent … and not even mentioned in HostMonster/Bluehost control panel. I’ve deleted the plugin from the MU folder and then deleted the caching folder. Hopefully it won’t come back!

    I am facing a similar issue. every time I open my site I see the address change to
    I contacted BH support and they told me to delete the plugins inside the mu-plugins folder that has the name cache and thats it.
    it didnt work.
    can some pls help on how to go about that specially with the .htaccess file mod.
    best regards.

    @bander33: in my BH installation, the .htaccess file was changed around 21st of December last year. The tech/script who installed it helpfully backed up the old .htaccess file, so I could simply copy the contents of the most recent prior to the change.

    You can find your .htaccess file in the folder /public_html/

    This is what mine looks like now (yours might need to look different, be cautious):

    # Use PHP54 Single php.ini as default
    # Changed PHP handler from application/x-httpd-php54s to application/x-httpd-phpbetas on Wed Jan 13 05:30:01 MST 2016.
    AddHandler application/x-httpd-phpbetas .php
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    # END WordPress

    There might be multiple backups of the .htaccess file in your root html folder, it seems BH has been experimenting with the cache plugins for a couple of iterations.

    Apart from the change to .htaccess, you need to delete or rename the two endurance_cache plugin files inside the /public_html/wp-content/mu-plugins folder. Just append .bak or something to them. You should not need to delete the /endurance_page_cache folder, it doesn’t matter.

    • This reply was modified 4 years, 9 months ago by mftsoftware.
Viewing 15 replies - 1 through 15 (of 26 total)
  • The topic ‘What is “/wp-content/endurance-page-cache/”? Creating thousands of directories?’ is closed to new replies.