Support » Plugin: Show/Hide Content at Set Time » What interfered here?

  • Resolved dozza

    (@dozza)


    I’ve switched to your plug (from another similar one) as it’s actively maintained and appears to be much more fully featured.

    I implemented a time restriction on a client school site over the weekend to reveal a button to an application form at midday on Saturday (10th Feb). The following is the exact text that was in the Divi Builder text module (although I’ve removed it now):

    [time-restrict on=”2018-02-10 11:59:59″ off=”2018-02-19 23:59:59″ else=”Our enrichment programme for the Summer term 2018 will be available to apply for from this page from midday on Saturday, 10th February 2018. The deadline for submitting applications is midnight of Monday, 19th February 2018.”]
    <h3>Our enrichment programme application process for the Summer term 2018 is now open.</h3>
    The form is available from midday on Saturday, 10th February 2018. The deadline for submitting applications is midnight of Monday, 19th February 2018
    [button link=”http://www.kilmorieschool.co.uk/parents/enrichment-clubs/apply-enrichment-music-clubs/”%5DApply Now![/button]
    [/time-restrict]

    The restriction didn’t work for some reason and the button wasn’t revealed so we had a bit of a panic which was easily resolved. I’d like continue using your product so I thought I’d enquire what I may have done wrong or, more likely, might be interfering with it functioning correctly.

    I have got WP-Supercache running on the site and we also route it through Cloudflare. Might it be a caching issue?

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Dave Clements

    (@thewanderingbrit)

    It could definitely be a caching issue. If your site/host caches pages, the page as it was when it was cached is what will continue to be shown unless the cache gets cleared. You could always use the DONOTCACHEPAGE constant to stop a page from being cached (or your given plugin’s cache settings)

    Thanks for that Dave.

    Might it also be the wrong speech marks I used in the shortcode?

    Plugin Author Dave Clements

    (@thewanderingbrit)

    That’s definitely a possibility. You need to be sure not to use curly quotes in shortcodes (and code in general), as they are not recognised as quotes like you would use in code.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘What interfered here?’ is closed to new replies.