Support » Plugin: WP Scripts & Styles Optimizer » What Does The “Require” Refers to?

  • Hi
    Thanks for all the effort invested in writing this Plugin. I was wondering what it means when you have the Red that says “Requires”.. Does that mean it’s safe to deactivate or move to the footer?
    Thanks

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Hendrik Lersch

    (@riddler84)

    Hello,
    this means that all the scripts, mentioned after the “Requires” are needed for that particular script. For example many scripts require jQuery in order to run properly, so it has to be included in the HTML code before the script, which needs it.

    But this is not much more than a notification. You can safely move scripts or styles in any direction (header or footer). The plugin takes care that all scripts are in the right order. Necessary scripts will be moved too, if needed. In that case you will get a notification, which files were moved.

    Thank you for your response. So is it safe to move 90% of the style & scripts to the footer?

    Thank you

    Plugin Author Hendrik Lersch

    (@riddler84)

    Yes, this shouldn’t be a problem. And you can always reverse it if you notice any functionality problems on your site.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘What Does The “Require” Refers to?’ is closed to new replies.