WordPress.org

Forums

WP Smush
[resolved] What does "jpg must be within the website home URL" mean? (7 posts)

  1. lmn927
    Member
    Posted 1 year ago #

    Every time I upload a picture it gives me an error that says "jpg must be within the website home URL." What does this mean? I am using wordpress and uploading to my media library.

    http://wordpress.org/plugins/wp-smushit/

  2. WPMU DEV
    Member
    Posted 1 year ago #

    Hi @lmn927,

    I hope you are well today and thank you for your question.

    The error message "jpg must be within the website home URL" displays because by default the plugin enforces that the image URL is the same domain as the home. If you are using a sub-domain pointed to this same host or an external Content Delivery Network (CDN) you should unset this option.

    To unset "Enforce image URL is same as Home" option go to the Settings > Media page and look for the Smush.it section. You will see a checkbox "Enforce image URL is same as Home" to turn off the enforce same URL check. Just uncheck it and try either Bulk Smush.it or individual.

    Best Regards,

  3. Hey there.

    We haven't heard from you in awhile, so I just wanted to check in to make sure all was good.

    This thread was marked resolved, but please, if you still need help then just respond and open it back up. We can then take it from there. :)

    Hope you have a fantastic day!

  4. clammy77
    Member
    Posted 1 year ago #

    Hi there, quick question.

    I have that settings set up (where my home domain is http://www.domain.co/wp-content...), however, when I submit my post, it will then force my images to go back to just domain.com/wp-content...

    This is very strange, because I had specifically checked that box so that all the images would have the same exact URL as my home domain.

    Please let me know how I can fix this. Thanks!

  5. WPMU DEV
    Member
    Posted 1 year ago #

    Hi @clammy77,

    Thanks for posting on the forums.

    I have that settings set up (where my home domain is http://www.domain.co/wp-content...), however, when I submit my post, it will then force my images to go back to just domain.com/wp-content...

    I didn't understand exactly what's the problem you are facing.

    Do you mean it's removing "http://" from the image path?

    Could you please share me a screenshot of it by uploading the screenshot on any image sharing website like http://imgur.com/ and sharing its unique URL here?

    Kind Regards,

  6. siahtirim
    Member
    Posted 1 year ago #

    Hi @lmn927,

    I hope you are well today and thank you for your question.

    The error message "jpg must be within the website home URL" displays because by default the plugin enforces that the image URL is the same domain as the home. If you are using a sub-domain pointed to this same host or an external Content Delivery Network (CDN) you should unset this option.

    To unset "Enforce image URL is same as Home" option go to the Settings > Media page and look for the Smush.it section. You will see a checkbox "Enforce image URL is same as Home" to turn off the enforce same URL check. Just uncheck it and try either Bulk Smush.it or individual.

    Best Regards,

    really thank u

  7. WPMU DEV
    Member
    Posted 1 year ago #

    Hi @siahtirim,

    You have just copy pasted the reply that i have posted in my following previous reply.

    http://wordpress.org/support/topic/what-does-jpg-must-be-within-the-website-home-url-mean?replies=6#post-4933189

    I didn't get your point doing it.

    Is there any help that you need from us?

    Please advise.

    Regards,
    WPMU DEV

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WP Smush
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.