WordPress.org

Support

Support » Installation » what did i do to cause this?

what did i do to cause this?

Viewing 15 replies - 1 through 15 (of 30 total)
  • in the file feed-rss2.php add the following line below the <channel> line

    <atom:link href="<?php bloginfo_rss('url') ?>/?feed=podcast" rel="self" type="application/rss+xml" />

    ok. I added exactly that in the code, directly below the <channel>.

    I am now getting:

    http://www.feedvalidator.org/check.cgi?url=http://learningwithyouripod.com/?feed=podcast

    I am wondering if about half way thru what you wrote above, that means I should write “my” url. If so, my url is http://www.learningwithyouripod.com . Is that how I write it? Do I use parathesis? Do I include the http? Or is this the wrong direction, altother?

    Thanks for the help. Thus far, they have been good directions to follow — just didn’t get the exact result I’m looking for. 🙂

    Moderator Samuel Wood (Otto)

    @otto42

    WordPress.org Tech Dude

    I still do not understand what the big deal is.

    It doesn’t break anything. It doesn’t stop anything. All it does is make the feed validator give a spurious error. That’s it. Big whoop.

    But, if you cannot cope with having it invalid for the next 4 freakin’ days or so, here’s the quick and simple way.

    Get this file:
    http://wordpress.pastebin.ca/957077

    Use that as your feed-rss2.php.

    You are funny. 4 days? Is that all? I can wait. BUT – the big deal for me is this:

    I’m new to this. I’m trying to do something I’ve never done before. I’m insecure with my abilities. I am not sure if I caused this or if I can fix it.

    So, forgive my overzealousness — I just really though I did something wrong. If its just a kink – I can wait 4 days. 🙂

    One more thing. It doesn’t allow me to insert the feed into itunes. It says I have not podcasts…something like that.

    That is a big deal to me.

    Otto42: I appreciate your link, very much. I still don’t know what to do with it.

    I don’t know what to copy or paste where. Obviously you’re technically more savvy than I am. I am a teacher trying to produce video podcasts on itunes.

    You aren’t giving step-by step directions and I have put so much work into this. The big deal, again, is that I can’t get it work. Thats the big deal.

    Should I delete everything and start again? Does the average person walking in off the street get directions? I have no clue what to do. I have watched more youtube videos than you can imagine and no one said, that I’d have to rewrite code in the Word Press software. No where on your site is that listed. Is there any step by step directions?

    If not, perhaps if I learn this, I can write them for other people like me. I’d be willing to do this.

    Moderator Samuel Wood (Otto)

    @otto42

    WordPress.org Tech Dude

    One more thing. It doesn’t allow me to insert the feed into itunes. It says I have not podcasts…something like that.

    That has nothing whatsoever to do with the problem you’re describing here.

    The big deal, again, is that I can’t get it work. Thats the big deal.

    Get what to work? See, you are not asking the right questions.

    You originally posted a link to the feed validator and said “can someone help me fix this”.
    You said nothing about iTunes.
    You said nothing about video podcasts.

    We cannot help you fix a problem when you don’t tell us what problem you’re trying to fix.

    Right now, your feed is completely broken, and I have no idea what you have done. Why don’t you start again, and this time, tell us about what the *REAL* problem that you’re having is?

    no one said, that I’d have to rewrite code in the Word Press software

    You don’t. If you’ve made any changes to the core code, then I suggest that you redownload the original, unaltered code, and put that on your site. Start fresh. You do not need to alter any core code to make podcasting work. You don’t even need a plugin, although most people doing podcasting do install the PodPress plugin.

    You are right. I haven’t been asking the right question. I’ve been piecing together something I know very little about. I’m not used to this.

    I am creating podcast’s (video) for iTunes, which is all I want to do.

    I did the “assuming” thing. I assumed that people here would know I wanted to put my stuff over on iTunes.

    I am going to start from scratch. My apologies. When I come back to this forum, I’ll come prepared to ask the right questions.

    Again. My apologies. Thanks for your help. Be back soon.
    C

    OK. I am finally ready to ask a half way decent question.

    First, my goal is to use this site to feed video podcasts thru iTunes.

    2. I am hosting with Bluehost.
    3. I installed, thru Bluehost, Word Press.
    4. I installed, a podpress plugin. I also installed two optional files, as indicated by the mightyspeak/podpress video tutorial.
    5. I plug in the information into the Podpress fill in the blank area.
    6. I uploaded ONE video podcast to the appropriate folder, called uploads, I believe.
    7. I made sure the upload worked, and I wrote an entry and submitted it.
    8. I tried to valide the feed. It is valid, but comes up with the same error as before. It says: on line 75:Missing atom:link with rel=”self” — here is the URL.
    Although it is a valid feed, iTunes says I don’t have any podcasts/vodcasts. So, the valid feed doesn’t work. http://www.feedvalidator.org/check.cgi?url=http://learningwithyouripod.com/?feed=podcast

    So, my ulitmate goal is to stream this thru iTunes. I can not get the link to work.

    What do I do?

    PS. In case I didn’t say, I reinstalled everything today and started from scratch.

    have you tried doing what was suggested?

    I have not tried to do what was suggested, because I would need a step-by-step direction.

    If someone give me code and tells me what file to paste it in, but doesn’t tell me exactly where to paste it — it is hard for me. I don’t understand.

    So instead of royally messing things up, and going round and round, I’m hopeful some one can help me. My ultimate goal is to have a valid feed, without any errors so that I can feed it thru feedburner and then put it on iTunes.

    At present, I’m stuck.

    Moderator Samuel Wood (Otto)

    @otto42

    WordPress.org Tech Dude

    Wait. Stop.

    Validating your feed is not the magic cure-all here. It’s also not the source of your problem.

    The main problem I see is that the video you uploaded is a WMV file. That’s not iTunes or iPod compatible. You should be uploading an MP4 or a MOV file, both made using Quicktime.

    If someone give me code and tells me what file to paste it in, but doesn’t tell me exactly where to paste it — it is hard for me. I don’t understand.

    I really don’t understand what the problem or misunderstanding is. I gave you the whole bloody file, right here: http://wordpress.pastebin.ca/957077

    THAT’S THE ENTIRE FILE. Put it in feed-rss2.php. Validation problem solved. What’s the issue?

    I’m feeling like less of a nitwit, now. I have been working with the wmv and the mp4 files. When I reinstalled the whole thing last night, I only linked the wmv. So, I’ve now changed it to an mp4 file.

    So, now the problem with your link that you sent me? The problem is not yours. It is mine. When I open it up I see a bunch of code. If I copy it, what file do I paste it in? Do I over-write a file? That where my loss is.

    So, now, I’m back to being a nitwit, again. I truly appreciate your help.

    THAT’S THE ENTIRE FILE. Put it in feed-rss2.php. Validation problem solved. What’s the issue?

    Do I copy this code and paste it over the existing?

    yes

Viewing 15 replies - 1 through 15 (of 30 total)
  • The topic ‘what did i do to cause this?’ is closed to new replies.