what did i do to cause this? (31 posts)

  1. stukel
    Posted 8 years ago #


    in English, with step by step directions, can someone help me fix this. i have NO idea what I've done.

  2. whistler2020
    Posted 8 years ago #

    in the file feed-rss2.php add the following line below the <channel> line

    <atom:link href="<?php bloginfo_rss('url') ?>/?feed=podcast" rel="self" type="application/rss+xml" />
  3. stukel
    Posted 8 years ago #

    ok. I added exactly that in the code, directly below the <channel>.

    I am now getting:


    I am wondering if about half way thru what you wrote above, that means I should write "my" url. If so, my url is http://www.learningwithyouripod.com . Is that how I write it? Do I use parathesis? Do I include the http? Or is this the wrong direction, altother?

    Thanks for the help. Thus far, they have been good directions to follow -- just didn't get the exact result I'm looking for. :)

  4. I still do not understand what the big deal is.

    It doesn't break anything. It doesn't stop anything. All it does is make the feed validator give a spurious error. That's it. Big whoop.

    But, if you cannot cope with having it invalid for the next 4 freakin' days or so, here's the quick and simple way.

    Get this file:

    Use that as your feed-rss2.php.

  5. stukel
    Posted 8 years ago #

    You are funny. 4 days? Is that all? I can wait. BUT - the big deal for me is this:

    I'm new to this. I'm trying to do something I've never done before. I'm insecure with my abilities. I am not sure if I caused this or if I can fix it.

    So, forgive my overzealousness -- I just really though I did something wrong. If its just a kink - I can wait 4 days. :)

  6. stukel
    Posted 8 years ago #

    One more thing. It doesn't allow me to insert the feed into itunes. It says I have not podcasts...something like that.

    That is a big deal to me.

  7. stukel
    Posted 8 years ago #

    Otto42: I appreciate your link, very much. I still don't know what to do with it.

    I don't know what to copy or paste where. Obviously you're technically more savvy than I am. I am a teacher trying to produce video podcasts on itunes.

    You aren't giving step-by step directions and I have put so much work into this. The big deal, again, is that I can't get it work. Thats the big deal.

    Should I delete everything and start again? Does the average person walking in off the street get directions? I have no clue what to do. I have watched more youtube videos than you can imagine and no one said, that I'd have to rewrite code in the Word Press software. No where on your site is that listed. Is there any step by step directions?

    If not, perhaps if I learn this, I can write them for other people like me. I'd be willing to do this.

  8. One more thing. It doesn't allow me to insert the feed into itunes. It says I have not podcasts...something like that.

    That has nothing whatsoever to do with the problem you're describing here.

    The big deal, again, is that I can't get it work. Thats the big deal.

    Get what to work? See, you are not asking the right questions.

    You originally posted a link to the feed validator and said "can someone help me fix this".
    You said nothing about iTunes.
    You said nothing about video podcasts.

    We cannot help you fix a problem when you don't tell us what problem you're trying to fix.

    Right now, your feed is completely broken, and I have no idea what you have done. Why don't you start again, and this time, tell us about what the *REAL* problem that you're having is?

    no one said, that I'd have to rewrite code in the Word Press software

    You don't. If you've made any changes to the core code, then I suggest that you redownload the original, unaltered code, and put that on your site. Start fresh. You do not need to alter any core code to make podcasting work. You don't even need a plugin, although most people doing podcasting do install the PodPress plugin.

  9. stukel
    Posted 8 years ago #

    You are right. I haven't been asking the right question. I've been piecing together something I know very little about. I'm not used to this.

    I am creating podcast's (video) for iTunes, which is all I want to do.

    I did the "assuming" thing. I assumed that people here would know I wanted to put my stuff over on iTunes.

    I am going to start from scratch. My apologies. When I come back to this forum, I'll come prepared to ask the right questions.

    Again. My apologies. Thanks for your help. Be back soon.

  10. stukel
    Posted 8 years ago #

    OK. I am finally ready to ask a half way decent question.

    First, my goal is to use this site to feed video podcasts thru iTunes.

    2. I am hosting with Bluehost.
    3. I installed, thru Bluehost, Word Press.
    4. I installed, a podpress plugin. I also installed two optional files, as indicated by the mightyspeak/podpress video tutorial.
    5. I plug in the information into the Podpress fill in the blank area.
    6. I uploaded ONE video podcast to the appropriate folder, called uploads, I believe.
    7. I made sure the upload worked, and I wrote an entry and submitted it.
    8. I tried to valide the feed. It is valid, but comes up with the same error as before. It says: on line 75:Missing atom:link with rel="self" -- here is the URL.
    Although it is a valid feed, iTunes says I don't have any podcasts/vodcasts. So, the valid feed doesn't work. http://www.feedvalidator.org/check.cgi?url=http://learningwithyouripod.com/?feed=podcast

    So, my ulitmate goal is to stream this thru iTunes. I can not get the link to work.

    What do I do?

    PS. In case I didn't say, I reinstalled everything today and started from scratch.

  11. whistler2020
    Posted 8 years ago #

    have you tried doing what was suggested?

  12. stukel
    Posted 8 years ago #

    I have not tried to do what was suggested, because I would need a step-by-step direction.

    If someone give me code and tells me what file to paste it in, but doesn't tell me exactly where to paste it -- it is hard for me. I don't understand.

    So instead of royally messing things up, and going round and round, I'm hopeful some one can help me. My ultimate goal is to have a valid feed, without any errors so that I can feed it thru feedburner and then put it on iTunes.

    At present, I'm stuck.

  13. Wait. Stop.

    Validating your feed is not the magic cure-all here. It's also not the source of your problem.

    The main problem I see is that the video you uploaded is a WMV file. That's not iTunes or iPod compatible. You should be uploading an MP4 or a MOV file, both made using Quicktime.

    If someone give me code and tells me what file to paste it in, but doesn't tell me exactly where to paste it -- it is hard for me. I don't understand.

    I really don't understand what the problem or misunderstanding is. I gave you the whole bloody file, right here: http://wordpress.pastebin.ca/957077

    THAT'S THE ENTIRE FILE. Put it in feed-rss2.php. Validation problem solved. What's the issue?

  14. stukel
    Posted 8 years ago #

    I'm feeling like less of a nitwit, now. I have been working with the wmv and the mp4 files. When I reinstalled the whole thing last night, I only linked the wmv. So, I've now changed it to an mp4 file.

    So, now the problem with your link that you sent me? The problem is not yours. It is mine. When I open it up I see a bunch of code. If I copy it, what file do I paste it in? Do I over-write a file? That where my loss is.

    So, now, I'm back to being a nitwit, again. I truly appreciate your help.

  15. stukel
    Posted 8 years ago #

    THAT'S THE ENTIRE FILE. Put it in feed-rss2.php. Validation problem solved. What's the issue?

    Do I copy this code and paste it over the existing?

  16. rudolf45
    Posted 8 years ago #


  17. stukel
    Posted 8 years ago #

    I copied lines 1-52 from Ottos link. I opened the appropriate file called: feed rss2. php. Now my feed is no longer valid. It says:


    There is another section on ottos link. It says: update post below. Perhaps he wanted me to post that over the orginal code?

    It is fantastic to have the file that corrects this. But when I open the file, copy lines 1-52 an then paste them over the orginal file, save, it, etc...it makes the problem worse.

    Otto keeps asking what the problem is. The problem is that I apparently dont know what to do with the code that he's sending me. I am copying it. I am pasting it. But I'm doing it wrong.

    I can also see by the other threads that I'm not the first person with this problem.

    I apologize for being such a pain. I just didn't think that this would involve such intricate work. I'm a software teacher, not a coder, or super techincal person. I appreciate any help. Thank you thank you

  18. whistler2020
    Posted 8 years ago #

    the error you are getting now is completely different... check the code that you pasted for any characters before the <? on line 1

    or post the code you have on line 1

  19. stukel
    Posted 8 years ago #

    When I went back to check the code, everything posted on line one. So, spaced it out so that the exact code is on the exact line.

    Still no luck.

    I have directly posted, directly pasted. I have no idea why it won't work.

    I'm becoming quite frantic. I really need this stuff up on itunes.
    Any more advice?

  20. whistler2020
    Posted 8 years ago #

    whats the code on line 1?

  21. stukel
    Posted 8 years ago #

    When I copy and paste the code from otto's link, it posts EVERYTHING on line one. Its as though the word wrap is turned off.

    So, I actually went and spaced it. But then I just put it back the way it pasted. Here is a sample of what I pasted. The line numbering appears off, here, but the code starts on line one and then stays on line one when I paste it in that file.

    header('Content-Type: text/xml; charset=' . get_option('blog_charset'), true);
    $more = 1;

    <?php echo '<?xml version="1.0" encoding="'.get_option('blog_charset').'"?'.'>'; ?>

    <!-- generator="wordpress/<?php bloginfo_rss('version') ?>" -->
    <rss version="2.0"
    <?php do_action('rss2_ns'); ?>

    <title><?php bloginfo_rss('name'); wp_title_rss(); ?></title>
    <atom:link href="<?php self_link(); ?>" rel="self" type="application/rss+xml" />
    <link><?php bloginfo_rss('url') ?></link>
    <description><?php bloginfo_rss("description") ?></description>
    <pubDate><?php echo mysql2date('D, d M Y H:i:s +0000', get_lastpostmodified('GMT'), false); ?></pubDate>
    <generator>http://wordpress.org/?v=<?php bloginfo_rss('version'); ?></generator>
    <language><?php echo get_option('rss_language'); ?></language>
    <?php do_action('rss2_head'); ?>
    <?php while( have_posts()) : the_post(); ?>
    <title><?php the_title_rss() ?></title>
    <link><?php the_permalink_rss() ?></link>
    <comments><?php comments_link(); ?></comments>
    <pubDate><?php echo mysql2date('D, d M Y H:i:s +0000', get_post_time('Y-m-d H:i:s', true), false); ?></pubDate>
    <dc:creator><?php the_author() ?></dc:creator>
    <?php the_category_rss() ?>

    <guid isPermaLink="false"><?php the_guid(); ?></guid>
    <?php if (get_option('rss_use_excerpt')) : ?>
    <description><![CDATA[<?php the_excerpt_rss() ?>]]></description>
    <?php else : ?>
    <description><![CDATA[<?php the_excerpt_rss() ?>]]></description>
    <?php if ( strlen( $post->post_content ) > 0 ) : ?>
    <content:encoded><![CDATA[<?php the_content() ?>]]></content:encoded>
    <?php else : ?>
    <content:encoded><![CDATA[<?php the_excerpt_rss() ?>]]></content:encoded>
    <?php endif; ?>
    <?php endif; ?>
    <wfw:commentRss><?php echo comments_rss(); ?></wfw:commentRss>
    <?php rss_enclosure(); ?>
    <?php do_action('rss2_item'); ?>
    <?php endwhile; ?>

  22. DianeV
    Posted 8 years ago #

    They're not asking for the whole code (we can see it on the posted link) -- they're asking whether they're anything before the opening <? in your feed-rss2.php file.

    So: is there anything before the opening <? in your feed-rss2.php file? There should not be ... no spaces, no nothing. The file should just start with <? and nothing else.

  23. stukel
    Posted 8 years ago #

    There are no spaces before <?. There are no brackets, lines or anything. There is nothing.

    I put my cursor there and even tried to delete, in case there was a space I didn't recognize.

    I am definitely in my feed-rss2.php file within the wp-includes folder.

  24. rudolf45
    Posted 8 years ago #

    OMG, I can't believe it...
    You copied all those lines with the line numbers???

    Teacher or not, you should have figured out that the numbers are not part of the code.
    Scroll down on that pastebin page and find the field below where the code has been put in. Copy the code from there!

  25. stukel
    Posted 8 years ago #

    I can see I am making progress. When I copied the code and pasted it in the file, it did not come with the numbers.

    That being said, I can tell I've done something wrong. So, if you or someone could tell me the following:

    1. click on otto's link
    2. select lines 1-52 and....OR...whatever the second step is.

    Do you want me to click submit post? If so, after that, I would need to do what?

    As you can see, from a teacher's point of view, I'm not a technical person. I'm obviously stuck on something that is very simple to you and could probably be very simple to me, if someone could say something other than to paste it in the file.

    Will eagerly await a response....

  26. stukel
    Posted 8 years ago #

    1. I went to Otto's link
    2. I scrolled down and copied the code from the second section of code
    3. I pasted it in the feed-rss2.php file.
    4. I saved it
    5. Went to my site: learningwithyouripod.com
    6. Click on the podpress plugin
    7. Tried to validate the feed
    8. Here is what I got:http://www.feedvalidator.org/check.cgi?url=http://learningwithyouripod.com/?feed=podcast

    9. I have concerns about 2.5. Even though its out, Bluehost won't upload it for weeks.
    10. Once its uploaded and I going to have these same problems?
    11. I've been working on one little kink for weeks.

  27. stukel
    Posted 8 years ago #

    Update part II:

    Listen, I just want my stuff on iTunes. Thats my ultimate goal. I'm not as good as you guys. I'm out of my league. I'm a college professor, trying to put my stuff up on iTunes to meet the needs of my students. I want to be cool, but I am not.

    I have yahoo's instant messenger. My screen name is stukel. My e-mail is stukel@yahoo.com.

    I have one skill. My skill is for spotting talent. You all are very talented -- I would love to learn more about this stuff. I'll continue reading, watching videos, etc. Thanks. I'll keep signing back on and asking questions.

    I could just sit here, at 40, and let my brain rot. I'm really trying.

  28. stukel
    Posted 8 years ago #

    Me again. I've posted an ad on Craigslist to ask for help.


    I don't have much to offer, but it may be worth your while.

  29. stukel
    Posted 8 years ago #

    Good news! I was able to validate my feed and successfully upload my content to iTunes. Here was the solution.
    1. otto gave my code -- it was invalid
    2. so, when i pasted it to my feed-rss2.php file, it would not validate my feed.
    3. I kept trying and trying and trying. NO HOPE.
    4. I took a break and rested.
    5. I went back and read the thread of other writers.
    6. I referenced whister2020 notes on the second post.
    7. I opened up ottos code
    8. I pasted whisters line in on ottos code
    and YATZEE.


    Seems like a lot of techy people aren't good at step by step directions. I'm going to make it my mission to help others....

    Hugs. I'm sure I'll be back.

  30. DianeV
    Posted 8 years ago #

    Excellent. Glad to hear it.

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.