Support » Fixing WordPress » what cron file to run (wp-o-matic)?

  • to have my blogs auto-fetch should i be trying to run the cron file at

    domain/wp-cron.php

    or

    domain/wp-content/plugins/wp-o-matic/cron.php?code=101

    *i’ve searched and searched without finding an answer to this*

Viewing 11 replies - 1 through 11 (of 11 total)
  • The second…

    I get an error when trying to run the cron:
    /bin/sh: line 1:
    /home/******/public_html/blog/wp-content/plugins/wp-o-matic/cron.php?code=61d6ea5a:
    No such file or directory

    I get the same error

    me too. 🙁

    /home/myusername/public_html/sitename/wp-content/plugins/wp-o-matic/cron.php?code=randomcode
    -jailshell: /home/myusername/public_html/sitename/wp-content/plugins/wp-o-matic/cron.php?code=randomcode: No such file or directory

    Any idea?

    hey all.

    seems like the author of this baby has vanished for the time being. i’m no pro here but the cron job i’m running has worked fine for about a month. so in case it might help someone here’s the line i’m placing into my web hosts cron job input field:

    wget http://YOUR_DOMAIN_NAME.com/wp-content/plugins/wp-o-matic/cron.php?code=cd129988 >/dev/null

    suppose it goes without saying, but you’ll need to add your own url and whatever code WP-O-Matic gives you.

    best of luck.

    Hi, HOW do we add this????
    Can I just click, “add cron job” from my C panel and pop in the code that is listed in SimplePie plug in (which is recommended for running wp o matic.)

    I seem to have everything set up ok, but when I click on the fetch button, nothing happens.

    I am hoping that is because it is waiting for new content.

    Please advise, I would DO like for this to work so I can launch my project.

    thanks!

    @ebizwildfire

    That’s about it, yes.

    I didn’t want this running every 20 minutes so I changed the code in the wpomatic.php file to have it run every other hour.

    Line 160 and 161:

    # Cron command / url
    $this->cron_command = attribute_escape('* */2 * * * '. $this->getCommand() . ' ' . dirname(__FILE__)  . '/cron.php?code=' . get_option('wpo_croncode'));

    Then, in cPanel/Crontab choose standard method (instead of advanced) click to highlight ‘every other hour’ (make sure nothing else is highlighted although you can correct that in the next step); paste the command you want to use (http://YOUR_DOMAIN_NAME.com/wp-content/plugins/wp-o-matic/cron.php?code=UNIQUECODE) and commit/save the changes.

    Now, you can go back, choose advanced this time an you should see the command you pasted, set to run:

    M  H    D  M  W  Command
    *  */2  *  *  *  http://YOUR_DOMAIN_NAME.com/wp-content/...

    This Israeli dude knows how to gnaw on this kitty, thank goodness…

    Thank you so much. Two things….

    It says I don’t have a “cache” file and that I have to make it writeable. SO I added a folder in my c panel in the wp o matic folder. Simple Pie plugin said it passed all the tests but it’s not fetching.

    1. HOW do you change the code in wpomatic.php ???? Is that in wordpress (if so where) or in c panel?

    2. WHERE did you get that code from that you list above?

    3. Have you ever tried to run it without the cron option?

    Todah Rabah – Thanks so much!
    D

    Hey guy,

    Yeah, that wp-o-matic/cache/ folder got me too. Then, I need to change the permissions to 777 which I don’t like. I tried less permissive settings by the plugin borked. In a way it was a good thing because my db error log file (specified in wp-config.php) needed more open permissions too… (it won’t be there if you go looking 😉 )

    If you’re using PHP4, there is a PHP5 function in the wpomatic.php which needs a workaround.

    I’m experimenting with this on http://benefact.org

    I can’t get this thing to preserve incoming post timestamps. It worked once. Just once! But no more even with reinstalls. Anyway.

    1.) The system generated code appended to the end of the cron command is unique for each feed instance. So if you delete and add the same feed, the value will be different and you’ll need to update your cPanel cron command.

    2.) I got the code by following the steps I detailed above. I had cPanel generate the cron code using the ‘Standard’ method, then I went back using the ‘Advanced’ method to see the actual cron statement. There are many cron howto’s online too…

    3.) Nope. I want the cron option so I stuck with it until it (kinda’) worked.

    Al-Lo-Dava – You’re welcome so much!

    Cheers.

    er, my bad… once every 2 hours, not every minute of every second hour…

    M____H____D____M____W____Command
    0____*/2___*____*_____*____http://YOUR_DOMAIN_NAME.com/wp-content/…

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘what cron file to run (wp-o-matic)?’ is closed to new replies.