What causes plugins to fail? (3 posts)

  1. davitz
    Posted 10 years ago #

    Hi again.
    I'm still experimanting around with WP, like it a lot, but have one issue:

    I really would like to install BriansthreadedComments, but this beast seems for whatever reasons to be the only one plugin that does not show up in the Plugin-Manager... I'm with WordPress 1.5, use the basic install (with a first attempt of a custom theme as frontend), and installed the plugin into the required directory. Nothin' happens...

    Tried to reinstall WordPress, reinstall plugin (out of zipped download), restart server, restart computer, stare at plugin's source code, swear at plugin's source code, nothing helps...

    What could be the magic mantra to get it to work? (Would the sacrifice of a chicken be enough, or is a goat required?)

    Thanks already
    d. )

  2. ColdForged
    Posted 10 years ago #

    Brian's Threaded Comments is not a "simple" plugin. It requires not only an installation of the plugin file but the replacement of the comments.php file in your theme directory. This is likely why the WPPM doesn't handle it very well... the Plugin Manager is limited in what it will do during installation, and copying a file from the ZIP file into the current theme directory isn't something it does.

    Your best bet is to go directly to the source and install manually according to the instructions.

  3. davitz
    Posted 10 years ago #

    Hey ColdForged

    blockquoteYour best bet is to go directly to the source and install manually according to the instructions.

    Actually, I did everything according to the specs. Downloaded/Installed from source, replaced comments.php, but still, threadedcomments (which I understand is an updated version of nestedcomments) doesn't appear in WPPM.

    I just re-tried the whole procedure to no avail - the recent version isn't there, the older version appears, but breaks the 'post a comment'-form (blank page returned, comment not added) probably due to some incompabilities with WP 1.5.

    What really amazes me is that many positive feedbacks indicate that no other users have this issue, even though I run a "clean" (unaltered) version of WP!

    ... ??? ... (baffled a bit...)


Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.