• Resolved sholdowa

    (@sholdowa)


    Looking at what is installed along with the latest version ( 1.1.1 ) of wd-google-analytics.

    I see a load of stuff under the vendor folder. Obviously a script like vendor/phpseclib/phpseclib/travis/install-php-extensions.sh can only be successfully run by root ( and securitywise is pretty poor anyway ).

    What on earth are they doing, attempting to compile stuff, download stuff from github and the like.

    Please do something about this, and revert to *only* including what is required to run this plugin, rather than attempting to add your devops stuff to a CMS – it circumvents any security measures that are in place!

    The page I need help with: [log in to see the link]

Viewing 1 replies (of 1 total)
  • Hello, @sholdowa!

    Thank you for posting your question!

    Please note, that Google Analytics WD plugin uses Google API PHP library. It includes several third-party PHP packages itself.

    Shell scripts are a part of the phpseclib project, but they are used neither in our plugin nor in Google library. We just did not delete all unused files one by one, however, we did remove folders in Google library.

    The whole library has a much larger size than what we have in the plugin. Feel free to delete these files, since that will not affect anything.

    Cheers!

Viewing 1 replies (of 1 total)
  • The topic ‘What are all these shellscripts?’ is closed to new replies.