• If I could give less than one star, I would

    It wouldn’t installed on WordPress 5.8. WordPress says it hasn’t been updated or tested on 5.8 and when I tell tme about the errors when I try to install it, they had the nerve to demand I pay for their “Premium” support to fix what is obviously THEIR PROBLEM

    There are lots of newsletter mailers that give better support than this!

Viewing 1 replies (of 1 total)
  • Plugin Support Bruna

    (@bruberries)

    Hi @phasar40,

    I believe you misunderstood our reply here.

    Despite you being a free user and we provide support for free users mostly here on the forums, we’re willing to investigate your error logs and get your issue fixed. That’s why we asked you to contact us through the Premium contact form, so we could receive your error logs and follow up with you via email.

    I believe you understood we were asking you to purchase a Premium license, but we actually just offered to help you via email by making an exception in this case.

Viewing 1 replies (of 1 total)
  • You must be logged in to reply to this review.