Support » Plugin: Next Active Directory Integration » Wget job – authorization failed

  • Resolved toftytophat

    (@toftytophat)


    Hi,
    I have got the AD Integration stuff setup and working in WordPress. When I sync in WordPress it syncs fine. When I try to sync using a Scheduled Task (I’m running on Windows) it fails. I get the following output:

    wget --post-data "next_ad_int-task=sync-to-wordpress&auth-code=MYAUTHCODE" http://MYSERVER.COM.AU/wp-admin/admin.php
    SYSTEM_WGETRC = c:/progra~1/wget/etc/wgetrc
    syswgetrc = C:\WGET/etc/wgetrc
    --2017-01-18 07:52:39--  http://MYSERVER.COM.AU/wp-admin/admin.php
    Resolving MYSERVER.COM.AU... 1.1.1.1, fe80::0000:0000:0000:0000
    Connecting to MYSERVER.COM.AU|1.1.1.1|:80... connected.
    HTTP request sent, awaiting response... 401 Unauthorized
    Authorization failed.
    • This topic was modified 3 years, 6 months ago by toftytophat.
Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author tobi823

    (@tobi823)

    Hi,

    I think that an other plugin causes a conflict. On my WordPress instance (with only the NADI plugin) it works:

    curl –data “next_ad_int-task=sync-to-wordpress&auth-code=Sr3wC7FbOgMoedhZBp5W” http://localhost/wordpress47m/wp-admin/admin.php

    
    [INFO ] Start of Sync to WordPress <br />[INFO ] LDAP connection is *not* encrypted <br />....

    Can you try to trigger the “Sync to WordPress” with:
    wget –post-data “next_ad_int-task=sync-to-wordpress&auth-code=MYAUTHCODE” http://MYSERVER.COM.AU

    or with:
    wget –post-data “next_ad_int-task=sync-to-wordpress&auth-code=MYAUTHCODE” http://MYSERVER.COM.AU/wp_login.php

    ?

    • This reply was modified 3 years, 6 months ago by tobi823.

    Hi Tobi823,

    Thanks for the response. In the end it turned out to be my IIS authentication settings. I modified them, and now it works perfectly.
    Thanks
    Luke

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Wget job – authorization failed’ is closed to new replies.