Support » Plugin: Wordfence Security - Firewall & Malware Scan » WF breaking WP All Import importing

  • wasanajones

    (@wasanajones)


    thanks for this great plugin

    any ideas on what settings can be changed to keep Wordfence from interfering with the WP All Import import updating the DB?

    it allows WP All Import to import the file to be uploaded and read (nodes visible to be mapped), but the next to the last step before posting is blocked

    there is no WF error message, but the admin page is stripped to almost blank but has links to WP All Import documentation. since admin is wiped out I can’t see anything wrong in Query Monitor.

    I contacted my Host and asked them to look at server logs but they are not seeing anything.

    I tried setting Web Application Firewall Status to learning mode, and disabled but still blocked

    Disable Code Execution for Uploads directory – disabled; still blocked

    deleted and reinstalled Wordfence with delete tables

    it is for sure caused by conflict with WP All Import and Wordfence. this is a WP multisite with WF network activated

    any help appreciated

Viewing 10 replies - 1 through 10 (of 10 total)
  • wasanajones

    (@wasanajones)

    the actual error is from using too much memory

    not sure how/why Wordfence is making WP All Import take up a lot of memory, but it is

    (everything works fine with Wordfence disabled)

    Plugin Support wfdave

    (@wfdave)

    Hi @wasanajones,

    Can you provide me with your host’s maximum memory quota?

    Can you take a screenshot of what you see at the last step (where it’s blocked/stripped of all content)?

    Before reaching that step, can you open the developer console (F12) and then going to the last step? Look at the console and network tab to see if anything is there. (Such as 404 errors in the network tab, or JavaScript errors in the console)

    Dave

    wasanajones

    (@wasanajones)

    Hi – thanks for the response

    PHP and WP Memory allocation is 256M, the server has 4GB RAM

    good tip about using F12 dev console — but right now I am no longer testing and have disabled Wordfence — I invested about 8 hours in the whole process and while I am a firm supporter and advocate of Wordfence — I’ve had to move on to another solution until I can revisit and see what happens

    I’ll be creating a new website to test on

    this is a WP Multisite Network, Wordfence network activated

    regards

    Hi –

    can’t live without either plugin !
    w

    wp-admin/admin.php?page=pmxi-admin-import&action=confirm

    produces unformatted page containing just a couple of links

    using F12 browser console see error
    Failed to load resource: the server responded with a status of 500 ()
    admin.php:1
    >

    wordpress multisite network, wordfence network activated, wp all import activated per site. WP All Import works fine right up to the step just before the import

    no idea if this is happening on other installs or just my particular setup

    regards,

    Exact same issue here.
    Would love to know the resolution.

    Did anyone find a solution to this problem yet? We are having the same issues!

    After working with the support people on All Imports, I tried at beta version which worked on our staging site, but the problem remained in the live site.
    Puzzling because they are an exact clone of each other.
    For now I disable Wordfence when I need to run the import.
    The error produced is just a generic 500 error. Not very helpful.

    • This reply was modified 1 month, 1 week ago by  NeilAtw.

    I thought the error was coming from a php/wordpress/server memory misconfiguration – however I’ve got my memory issues aligned properly – and still seeing this problem

    I tried increasing max_execution_time – by a lot – and that’s not it either.

    I am purely guessing but I think it is due to a PATH issue of using on Multisite subsite (I think it breaks on the main site too, but I’m sticking to the path theory)

    if you submit the import with F12 Developer Network open it appears the
    admin.php?page=pmxi-admin-import&action=options
    admin.php?page=pmxi-admin-import&action=confirm

    have different initiator paths

    pure guesswork from an amateur

    this is a painful problem

    I can say @wasanajones that irt is not limited to multisite. Ours is a regular, standalone WP installation with the exact same symptoms.

    thanks for letting me know. guessing is the fruit of desperation

    you’d think it must have something to do with the WAF firewall, but even disabled it still breaks WPAllimport

    query monitor does show failure to GET wp all import pro scheduler connection – no idea if that is part of this issue or not

Viewing 10 replies - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.